Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1. #11
    Quote Originally Posted by Rescue1 View Post
    Did they fix this piston issue yet on current year models? I was contemplating selling my 2012 and getting something new. I wish Kawi came out with something completely new, and I also with Yamaha didn't have paper thin hulls.
    It looks to me like from 2017, and on, all's well. 2015 / 2016 there are some sporadic Piston issues here and there. JB


  2. #12

    Join Date
    Nov 2006
    Location
    Key West, Florida
    Posts
    13
    +1
    1
    So this happened to my 2015 310r Ultra twice, once at 48 hours and the other was at 71 hours. Both times I was just rec riding and noticed blue smoke during a cruise. Warranty covered both times, also the shop found a cracked head this last time and replaced that also. They used the same part numbers as shown above, FYI. The ski has been sitting for the last 6 months so it still needs to be broke in. Smartest thing I did was buy the extended warranty, just saying!!
    Last edited by dowellj; 01-16-2020 at 01:10 AM.

  3. #13
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Fort Myers, FL
    Posts
    242
    +1
    71
    Quote Originally Posted by john belton View Post
    It looks to me like from 2017, and on, all's well. 2015 / 2016 there are some sporadic Piston issues here and there. JB
    Negative, My 2018 310's pistons failed 30 hours. They used 300 pistons in the rebuild.. I'm at 115 hours and no issues.
    My 2015 310 pistons failed at 40 hours they also used 300 pistons. I traded it in with 350 hours, engine ran perfect and didn't burn a drop of oil.
    If any of you guys have 310 piston issues make sure to ask for 300 pistons in the rebuild they are a more durable design.

  4. #14
    TJK's Avatar
    Join Date
    Apr 2013
    Location
    DesAllemands LA
    Posts
    126
    +1
    33
    My 17’ 310R Pistons went at about 75 hours. Mechanic said detonation caused it. Kawi fixed it under warranty but ski was never the same. When I sold it it would only do 67mph with an over ride.
    My wife’s 16’ (stock) lost a piston twice. Once at about 75 hours and again at about 100 hours. Rode it once since the last rebuild (Kawasaki covered both) but it has a strange dead spot in the throttle at about 60. Need to get it back so maybe they can figure that problem out.
    note.. these 310s have two ways to lose a piston. One they just break a ring land, the other is that they’re always running on the edge of detonation. It’s not easy to get 310 out of a 1500cc motor. always make sure you have the freshest and highest octane fuel in your 310.
    After the first motor went I started using klotz octane booster.

  5. #15
    Pretty much same story on one of mine except I rebuilt the engine myself (took a year). It runs great now but I'm leery of running wide open for extended periods of time. I'll open it up, hit top end speed for a few seconds, then get out of it. I can only imagine the strain inside there with all that boost, heat, rpms etc. Mostly I just try not to think about it lol!

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Feed Back For Ultra 310 Lineup
    By RXTX2012 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 01-02-2020, 08:49 AM
  2. Feed Back For Ultra 310 Lineup
    By RXTX2012 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 12-27-2019, 10:29 AM
  3. 2017 Kawasaki ultra 310 connecting rod failure
    By Ninja10 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-19-2018, 01:47 PM
  4. Ultra 310 Piston Issue
    By cihatcihangir in forum Kawasaki How To & FAQs
    Replies: 9
    Last Post: 08-06-2017, 05:57 PM
  5. GP1200R Rebuilding after WSM piston failure; back to OEM
    By Integragated in forum Yamaha Projects & Build Threads
    Replies: 11
    Last Post: 08-12-2013, 07:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •