Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30
  1. #11
    tiderider's Avatar
    Join Date
    Oct 2018
    Location
    Usa
    Posts
    527
    +1
    13
    Quote Originally Posted by Jhubbs255 View Post
    Sounds good I'll order everything. I have a press at my shop I think that will do the trick. The bolt the impeller goes on its a little rusty and the seal around that has some corrosion so it needs done either way. Thank you guys. Keep the info coming
    That impeller bolt is part of the oil pump shaft, probably a good idea to replace as well.

  2. #12
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    187
    +1
    6
    Actually the bolt looks good just a little brown so hoping it's good

  3. #13
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,187
    +1
    2,039
    My ski is open loop cooling, uses an enlarged restrictor at the pump (1/2" vs 3/8" ), with the WP impeller installed, plus the addition of a 5mm restrictor to the "IN" line for the oil cooler.

    All incoming water goes thur a strainer/intercooler, then distributed via 3 outlets to where needed. IMO, using the WP impeller helps with low rpm water flow to the head AND helps retain the seals between the cooling system and oil pump.

    My ski has never experienced a water leak from the weep hole. Ski uses a 160*F thermostat and highest engine temp has been around 165*+/- during summer time. In December, about 150-157F*.

  4. #14
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    187
    +1
    6
    So this is what my water pump looked like when i removed it??
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	WaterPump.jpg 
Views:	115 
Size:	58.4 KB 
ID:	457375  

  5. #15

    Join Date
    Aug 2013
    Location
    Connecticut
    Posts
    127
    +1
    23
    That's pretty insane that the engine got so hot it melted the impeller like that!

  6. #16
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    187
    +1
    6
    I thought MAYBE the previous owner put some plastic weld or epoxy to cover up something. The front has a block plate so its been modified instead of a newer Riva billet housing

  7. #17
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    187
    +1
    6
    I'm trying to replace the rotary valve but when I press the shaft through it pops the top cap off the valve. I've broken 2 now. Any idea on how the keep that flimsy valve in one piece while inserting the impeller shaft

  8. #18
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    2,069
    +1
    261
    Rotary valve? On the water pump shaft? Not sure what your refering to. You should have a rubber seal and then the metal water pump seal.

  9. #19
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    187
    +1
    6
    Water pump seal. Spring loaded.

  10. #20
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    2,069
    +1
    261
    You need something to support the seal when installing the shaft. A
    Water Pump Seal Pusher is what the manual states to use.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	water pump seal.jpg 
Views:	25 
Size:	79.4 KB 
ID:	457464  


Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bilge pump issue and no water from water pilot
    By Pullen724 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 02-18-2019, 09:22 AM
  2. Replies: 10
    Last Post: 07-16-2018, 05:39 AM
  3. Notify USCG of water intrusion issue - GP 1800 tunnel cracking issue
    By TwoBurgers in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 05-14-2018, 05:16 PM
  4. Weird issue: Area next to pump tunnel filling up with water - when ski out of water??
    By mfslacker22 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-25-2016, 08:02 PM
  5. Replies: 41
    Last Post: 09-01-2010, 10:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •