Results 1 to 10 of 10
  1. #1

    Join Date
    Sep 2006
    Location
    Houston Texas
    Posts
    370
    +1
    10

    Lost a Piston in Ulta 150

    Lost the number one piston in 2001 Ultra 150. Caught just in time as no damage to crank, and cylinder wall. Question is what do you think caused it ? Oil, and cooling lines are clear. By the other 2 pistons, ( both at 130 psi), thinking a lean condition caused by carbs ?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20191229_121537.jpg 
Views:	45 
Size:	82.5 KB 
ID:	456921   Click image for larger version. 

Name:	20191229_142625.jpg 
Views:	38 
Size:	146.9 KB 
ID:	456922   Click image for larger version. 

Name:	20191229_142639.jpg 
Views:	40 
Size:	134.1 KB 
ID:	456923  

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,905
    +1
    668
    Looks like the ring gap is aligned with the exhaust port.

  3. #3
    Let me out of here......I need to go on Greenhulk!
    Join Date
    Jun 2008
    Posts
    500
    +1
    22
    Quote Originally Posted by steve45 View Post
    Looks like the ring gap is aligned with the exhaust port.

    Ring probably moved once the pin was gone.

    May be fuel system related. How old is the fuel? You could put the heads back on and pressure test the motor to rule out air an air leak.

  4. #4

    Join Date
    Sep 2006
    Location
    Houston Texas
    Posts
    370
    +1
    10
    Fuel is new 95 octane is the highest I can get here in Thailand. Going to to rebuild the carbs, checked the fuel pump, and they is a very small tear in the rubber. My guess was not getting enough fuel. Can I use a aftermarket Mikuni fuel pump ? Was looking at the 35 liters per hour model. Maybe mount it to the side of the ski inside, and run new lines.

  5. #5
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,664
    +1
    192
    Are you sure it was not something as simple as a cooling system issue? Do you have a tripple pisser kit? Is the L fitting on the cylinder head all clear?
    Rairly if ever have i seen the fuel pump "too" weak to supply the fuel. They work or don't.
    Also there is a fuel strainer in the carbs under the needle and seat that may be obstructed.

    If it were me,
    New oil lines (can't hurt) Just be sure correct one to correct port
    Clean carbs, check fo any failed parts, be sure sliders move freely and equal
    Set up carbs, per manual, (don't have a manual, get one)
    Check reeds
    Add tripple pisser kit
    Replace fuel filter
    and of course new piston and rings
    Last edited by SplishSplash; 12-31-2019 at 10:11 AM.

  6. #6
    Is this that ski that was posted with 180psi??????


  7. #7
    Let me out of here......I need to go on Greenhulk!
    Join Date
    Jun 2008
    Posts
    500
    +1
    22
    Quote Originally Posted by turboman412 View Post
    Is this that ski that was posted with 180psi??????
    Whoops.....

  8. #8
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,905
    +1
    668
    The plot thickens...

  9. #9
    Let me out of here......I need to go on Greenhulk!
    Join Date
    Jun 2008
    Posts
    500
    +1
    22
    180 psi must have been a typo. The original post says the other 2 cylinders are at 130 and looks like a stock head in the background.

  10. #10

    Join Date
    Sep 2006
    Location
    Houston Texas
    Posts
    370
    +1
    10
    No typo, just confusion and two broken ski's at the same time, The Ultra is or was at 130 across the cylinders, and the X2 is or again was at 180 psi. Having issues with the X2 as well. On the ultra going for a complete rebuild and good used cylinder heads, as I found out the heads were milled, a common practice here to make it a " race boat". The X2 has a ADA head, keeps bogging out. About ready to give-up on the skis, and go back to the bars, cheaper hobby.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts WTB Ulta 150 Upgrades
    By ktyamaha36 in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 08-11-2016, 09:20 PM
  2. 07 gpr lost rear piston
    By Bryonjodinolan in forum Yamaha PWC Performance (2-stroke)
    Replies: 29
    Last Post: 06-30-2016, 09:26 PM
  3. Lost oil pressure piston pin
    By Tony2k in forum MSX/Matrix
    Replies: 3
    Last Post: 06-20-2015, 02:54 AM
  4. Need Carborator set and fuel pump - FOR KAWASAKI 150 ulta
    By noe173 in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 07-09-2013, 08:07 AM
  5. Help! Ulta 150
    By ultra150man in forum Kawasaki PWC Performance (4-stroke)
    Replies: 19
    Last Post: 05-21-2007, 10:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •