Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
  1. #11
    So I took the ski out today with a fuel pressure gauge on the supply line to the rail. For the first 5 mins fuel pressure held 42psi at WOT then it started to drop and fluctuate from 25-30psi. Looks like a dodgy fuel pump. I think I’m better off biting the bullet and ordering the whole assembly given it is 7 years old now.

  2. #12
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,507
    +1
    691
    Quote Originally Posted by Ausjet01 View Post
    Quick update, checked the intercooler, was clean, fitted a new fuel vent valve, SCOM wiring looked fine, checked fuel flow on 3 second prime was on spec at ~90ml. Took it out this arvo- still surging. Maybe it’s compression related given it only starts faulting after 5 mins of riding. Or an inaccurate tps, clutching at straws now ��
    The book is wrong....90 mls is incorrect.
    150ml is required at min
    Your pump is stuffed and or your carbon filter in the tank is blocked to shit.... flush it out via back flushing it
    150ml+@ 3sec and 43+psi at Wot is required for correct operation.

    Waz
    Last edited by sirbreaksalot; 01-03-2020 at 06:28 PM.


  3. #13
    Quote Originally Posted by sirbreaksalot View Post
    90 mls is incorrect.
    150ml is required at min
    Your pump is stuffed anchor your carbon filter in the tank is blocked to shit....
    150ml and 43 psi is required for correct operation.

    Waz
    I was going off the workshop manual. It says 83ml at a minimum. That gave me a bump steer thinking it was good. Thanks mate Iíll order a new pump assembly

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 150 wonít rev past 4000
    By Rxpx260rider in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-04-2019, 05:05 PM
  2. Genesis 1200 won't rev past 5k
    By blackstang in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-18-2018, 07:24 PM
  3. 99 GTX won't rev past 6200
    By Bryanford in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-10-2016, 10:58 AM
  4. MSX150 won't rev past 4400
    By matfan in forum Polaris PWC Performance
    Replies: 2
    Last Post: 12-01-2013, 06:46 PM
  5. 96 sltx won't rev past 5600rpm
    By raiderman444 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-09-2009, 11:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •