Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1

    2015 FX SVHO Rough Idle after 20 seconds?

    Admin, if I’m posting in the wrong section, forgive me and please fix.

    I currently have a 2015 FX SVHO with a few mods that wants to idle rough after a few seconds.

    This ski got a Fizzle intercooler last summer and has not run right since. First run post Fizzle it was doing this bad idle and would not top out above 60mph. At first I assumed a bad tune and left it on the trailer. I have 2 other skis and other hobbies that have kept me busy since.
    In April of this year my 2015 FZS started losing power and it ended up being a bad clutch. That was fixed under warranty and is back to mid 80’s.
    Once I got the FZ dialed back in I shifted focus back to the FX and realized perhaps the clutch is bad too. Sure enough it was but I got denied warranty by RPM ONE for the presence of aftermarket parts. The FZ has the exact same mods so why they fixed that one and not the FX is beyond me. I obviously have a case for breach of warranty, but being as I could just do it myself for the cost in parts I decided it wasn’t worth the effort to go to court.
    So I did the clutch replacement myself and haven’t yet got it on the water. Please see video.

    She cranks up and idles smooth just fine. But after 15-20 seconds or giving a little gas she wants to sputter and pop.
    RPM’s are jumping 100-200 up and down. Idles fast then sounds like it is going to stall.

    I assumed perhaps the intake mount is split causing a loss of boost but that would cause issues through the power band and not just idle. She seems to rev fine and pegs out to 7500+ on the tach, on trailer anyway.
    I have even unplugged each injector and each spark plug connector while idling and it only gets worse, proving it’s not already missing.

    I then thought maybe the clutch went in wrong but remembered it was doing this before.
    The solas impeller did go in super tight, perhaps it’s catching??

    Mods are: Solas prop, riva intake, fizzle, ribbon delete, 2019 super chargers on the 2015’s, water strainer, water cooling line upgrade and diode delete.
    Stock tune at moment.


    https://youtu.be/2GpO2386DjA

  2. #2
    Change the plugs?


  3. #3
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,106
    +1
    1,977
    Suggestions;

    Remove the impeller and driveshaft. See if the engine now idles happily.

    While it is out you can inspect for indications of impeller binding inside the jet pump.

    Install fresh spark plugs. Sometimes fresh plugs solve problems.

  4. #4
    Thanks for the suggestions on the plugs. It’s just that i don’t think this ski has even an hour of use on it since the last service which gave it new plugs. Alas that may be the issue. ��, dud plug from dealer.

    I’ll do plugs first...

    I could yank the pump again too, but dammit that’s a job!

    I’ll try both of these tomorrow and let you know what I find!!

  5. #5
    Quote Originally Posted by K447 View Post
    Suggestions;

    Remove the impeller and driveshaft. See if the engine now idles happily.

    While it is out you can inspect for indications of impeller binding inside the jet pump.

    Install fresh spark plugs. Sometimes fresh plugs solve problems.

    would you say these have a lot of soot? Maybe from riding too rich, from the bad clutch and not getting enough boost / air??

    thoughts?

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	354F62A2-30E4-4375-9BE0-C7803B42D277.jpg 
Views:	112 
Size:	89.4 KB 
ID:	456681  

  6. #6
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,106
    +1
    1,977
    Quote Originally Posted by Floon34 View Post
    Thanks for the suggestions on the plugs. It’s just that i don’t think this ski has even an hour of use on it since the last service which gave it new plugs. ... plug from dealer.

    ...
    What is that white goop on the spark plug threads?

    If that is anti-seize compound, that looks like an awful lot more than ‘enough’.

  7. #7
    Lol yep my thoughts exactly. Apparently something dealership does. I’ll buy new plugs tomorrow regardless and give it a shot. If that doesn’t fix it I’ll yank the pump again ugh soooo tired of doing that. Between 3 skis and the various mods I’ve gotten damn good at it...

  8. #8
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    2,052
    +1
    255
    Quote Originally Posted by K447 View Post
    What is that white goop on the spark plug threads?

    If that is anti-seize compound, that looks like an awful lot more than ‘enough’.
    Looks like plumber's tape (aka Teflon tape). I would look for another dealership if they did it.

  9. #9
    Quote Originally Posted by ncdoo View Post
    Looks like plumber's tape (aka Teflon tape). I would look for another dealership if they did it.
    it’s not plumbers tape. It’s a white grease to prevent seizing. Cycle springs in Tampa area...

  10. #10
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    2,052
    +1
    255
    Quote Originally Posted by Floon34 View Post
    it’s not plumbers tape. It’s a white grease to prevent seizing. Cycle springs in Tampa area...
    Most anti seize I've seen is grey/silver in color. Whatever it is they used way too much.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2018 svho engine rough idle
    By wilsonma in forum Yamaha PWC Performance (4-stroke)
    Replies: 20
    Last Post: 12-13-2019, 12:40 PM
  2. FZR SVHO Rough idle
    By ValBugi in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 04-22-2017, 09:04 AM
  3. Rough Idle and stalling 15 FX SVHO
    By JohnnyMac in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-22-2015, 08:26 AM
  4. Advice on intake grate, to improve rough water hookup (2015 FZ SVHO)
    By UnleashedBeast in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-06-2015, 07:26 PM
  5. Ultra 250X Problems - Rough Idle, will not go past 25MPH, runs rough
    By troye in forum Kawasaki PWC Performance (4-stroke)
    Replies: 21
    Last Post: 10-09-2012, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •