Page 1 of 3 123 LastLast
Results 1 to 10 of 28
  1. #1

    RXT 260 AS stickin between 7650-7450

    Hello guys, I have a problem, may be somebody of you can help me. I have a 2012 RXT 260 as with 70 hours. Intercooler fizzle, Riva powerfilter and solas 14/19. I am running at sea level, air 32 deg, water 27 deg. In the last 20-30 hours I noticed a drop in performance at full throttle. It accelerates till 7200 rpm very fast, than arrives at 7660 max, than itís like a limiter that is kicking in, it drops till 7400, than accelerate again till 7660 an so on... I clearly can feel on the handlebar the acceleration that stops, than start again, than stops. itís like it try to go faster but itís blocked by something...max speed is around 65. Before it was 69. Intercooler is new, supercharger is still good (the mechanics told that). Inlet temperature sensor is new (failed 10 hrs ago causing p0127). No alarm on now. Some idea? Can you help me please? I really donít know what to think about.


  2. #2

    Join Date
    Sep 2019
    Location
    Philadelphia
    Posts
    46
    +1
    2
    Hey bud. What your describing could be several different issues. But it does sound like you are experiencing a boost leak. Check the intercooler and charger hose clamps

  3. #3

    Join Date
    Sep 2019
    Location
    Philadelphia
    Posts
    46
    +1
    2
    After reading your post again. Few things for you to look at. How old are spark plugs?? Check Charger/ intercooler hoses and clamps. Also a partially dirty fuel injector will cause your inconsistent
    rpm aswell. They are very simple to remove and do a visual inspection
    Last edited by Yamafzs; 11-30-2019 at 07:29 PM.

  4. #4
    Can you explain to me how to remove an to understand if it is dirty? If it is dirty, how to clean?

  5. #5

    Join Date
    Sep 2019
    Location
    Philadelphia
    Posts
    46
    +1
    2
    Look at top of your motor. Fuel line comes in from tank. Thats your injector rail. Remove the rail. And injectors will come right out. (Be mindful of the black o rings falling off. Look at injectors. (Bottom) I take pic and then blow up image. Looking for obvious discoloration. Or if one looks diff from others. Spray them with cleaner. If they are really dirty. Then the procedure is much more involved. Youtube will provide alot of "how to" i would pull spark plugs. And post a pic of all three of them. You may get lucky. And just have a bad plug

  6. #6

    Join Date
    Sep 2019
    Location
    Philadelphia
    Posts
    46
    +1
    2
    There is a few bolts that hold rail to engine. Few zip ties to snip. Fuel line from tank does not need to. BE removed. Pull up on rail. Be Mindful of fuel spillage. Injectors are now free. Remove. Put on work table. Get some. Fuel injection spray. Or carb choke spray. Juice them up. Politely pat them wit cloth. Then re-do

  7. #7

    Join Date
    Sep 2015
    Location
    OC MD
    Posts
    125
    +1
    2
    do you still have the speed limiter, boost limiter?27 deg water temp where are you Alaska?
    Quote Originally Posted by Lucky_luke View Post
    Hello guys, I have a problem, may be somebody of you can help me. I have a 2012 RXT 260 as with 70 hours. Intercooler fizzle, Riva powerfilter and solas 14/19. I am running at sea level, air 32 deg, water 27 deg. In the last 20-30 hours I noticed a drop in performance at full throttle. It accelerates till 7200 rpm very fast, than arrives at 7660 max, than it’s like a limiter that is kicking in, it drops till 7400, than accelerate again till 7660 an so on... I clearly can feel on the handlebar the acceleration that stops, than start again, than stops. it’s like it try to go faster but it’s blocked by something...max speed is around 65. Before it was 69. Intercooler is new, supercharger is still good (the mechanics told that). Inlet temperature sensor is new (failed 10 hrs ago causing p0127). No alarm on now. Some idea? Can you help me please? I really don’t know what to think about.

  8. #8
    Yes the limiters are still there, not yet maptuned, i will do soon the 8350. For the temperature, I am Italian but I am running in Angola, Africa , 27 DegC, 81 Deg F! I Will try to change the spark plugs, and clean the injectors. Can’t be some bad sensor that give fake informations to the ecu? When I had the intake temp sensor faulty, before going in limp mode the behaviour was very similar. The strange thing is that the acceleration is very robust, goes till 7600 even 7700 than goes down, than try again to go up....

  9. #9

    Join Date
    Sep 2015
    Location
    OC MD
    Posts
    125
    +1
    2
    i have 2013 rxtx as and it would do the same thing ,it is all the limiters
    Quote Originally Posted by Lucky_luke View Post
    Yes the limiters are still there, not yet maptuned, i will do soon the 8350. For the temperature, I am Italian but I am running in Angola, Africa , 27 DegC, 81 Deg F! I Will try to change the spark plugs, and clean the injectors. Can’t be some bad sensor that give fake informations to the ecu? When I had the intake temp sensor faulty, before going in limp mode the behaviour was very similar. The strange thing is that the acceleration is very robust, goes till 7600 even 7700 than goes down, than try again to go up....

  10. #10
    But when I was stock I was 110 on 8000. After I raplaced impeller with solas 14/19 and metal bearing I was on 110 on 7800, but I didn’t feel the limiters like now. So this difference may be only due to the heat and soak in African summer that are anticipating the intervention of the limiter? So once maptuned, problem solved?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxt 260 2010-11 same mm opening nozzle as 2012-up Rxt 260?
    By zpeedray in forum 4-Tec Performance
    Replies: 5
    Last Post: 12-29-2016, 03:41 PM
  2. SOLD R & D Intake Grate 255 GTX iS, 260 RXT-X, 260 RXT iS 113-95006
    By nlpnrxt1 in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 09-10-2015, 07:11 PM
  3. 06 Rxt wont pass 7650 RPMS Need Help
    By dbullet2 in forum 4-Tec Performance
    Replies: 72
    Last Post: 03-25-2014, 10:36 PM
  4. SOLD R&D Intake Grate 255 GTX iS, 260 RXT-X, 260 RXT iS
    By 8 is enough in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 10-06-2012, 08:17 PM
  5. RIVA releases Stage 1 kit for RXT-X 260 and RXT 260
    By Green Hulk in forum 4-Tec Performance
    Replies: 17
    Last Post: 02-07-2011, 04:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •