Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
  1. #11

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,655
    +1
    949
    Feels like a blown off IC hose/air leak...or map sensor.

  2. #12

    Join Date
    Oct 2019
    Location
    Lake Conroe, TX
    Posts
    13
    +1
    2
    Quote Originally Posted by Scott View Post
    Do you have a way to reset the throttle body?
    no idea Iím still learning about this stuff


  3. #13

    Join Date
    Oct 2019
    Location
    Lake Conroe, TX
    Posts
    13
    +1
    2
    Was a vacuum leak, a small screw was missing out of the intake or ribbon delete kit. Like a super tiny plastic screw that was just letting raw air in. The dealership is going over everything, took it to Mancuso South and a guy named Adam is working on it who has raced skiís for years and had few modded skis at the shop.

  4. +1 by:


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT-X 300 Rough Idle is there a fix?
    By flnsx in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-03-2019, 09:49 AM
  2. 300 extended idle becomes rough
    By Sandman_73 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-11-2017, 09:07 PM
  3. 2016 RXPX 300 rough idle
    By 2011gti in forum 4-Tec Performance
    Replies: 12
    Last Post: 09-11-2016, 10:42 PM
  4. Replies: 8
    Last Post: 08-24-2014, 06:49 PM
  5. Rxpx idle rough high and low
    By hijakdgtr in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-31-2012, 02:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •