Results 1 to 9 of 9
  1. #1

    Exclamation 2016 SEADOO RXP-X 300 Not Starting

    Good Day,

    I have a 2016 Seadoo RXP 300, it had salt water damage on the Intercooler and Throttle, I bought the ski from a friend,
    Plugged into CANDOO Pro and had several errors listed below:
    - P060E
    - P106E
    - P1615
    - P1619
    - P1620
    - P1622

    Most of these were active so i decided to physically check the Throttle body, both the throttle body and intercooler were full of salt (the previous owner confessed later that he never flushed the jet after use in Salt water, he used it like this for a whole year),

    I tried to clean the TB but it was pretty stiff, after cleaning it a bit the Jet would start only with the Intercooler pipe disconnected from the Throttle body, it started but wouldn't rev properly and the errors were still there as active,

    So, I bought a new Intercoller and a new Throttle body, fitted to the jet and the errors went all from "ACTIVE" to "OCCURED", did a faults clear and no more errors,

    But the Jet does not start, it cranks and cranks but wont start,
    I check bellow:
    - OIL, old oil came out with no water residue or signs but it was pretty dark and thick, added new OIL
    - Fuel Pump - Working with Pressure, OK
    - New Spark Plugs - checked each one for sparks when cracking the engine, all OK
    - Removed the pipe that comes from the intercooler to the TB and after several tries it started but when I put the pipe back on it wont start
    - Airbox cleaned
    - A friend told me to do a TPS Reset on the CANDOO PRO, Did it and it reads around 7 to 8%









    I noticed also that when I take the plugs out, there is a bit of liquid, seems like water, but there is no coloration,

    At this point I do not know what else I need to do or Check,
    I have attached some videos and photos

    I need assistance,

    Thanks & Best Regards

  2. #2
    Hi mate
    salt water in intake can be a pain and it can create a lots of invisible problems,but to solve your problem Iíll take you back to basics.
    First up I suspect your engene has suffered surface corrosion on the valve train causing
    most of the valves not to shut properly and
    leak compression.
    Yes if you go back to basics to get engine to start we need: air fuel spark and COMPRESSION. Get your compression tested before you waist any more time and money , your engine being low comp you should get 120 to 150 psi the reading should be consistent on all 3 cylinders.
    If you only getting 90 psi your engine will still start but anything below 80 will be a struggle. Also how long has the engine been sitting ?
    Itís critical to remove salt water from intake and flush it with new liquid asap after water went in.
    Im talking hours not days!!!
    Good luck

  3. #3
    Quote Originally Posted by zmilos View Post
    Hi mate
    salt water in intake can be a pain and it can create a lots of invisible problems,but to solve your problem Iíll take you back to basics.
    First up I suspect your engene has suffered surface corrosion on the valve train causing
    most of the valves not to shut properly and
    leak compression.
    Yes if you go back to basics to get engine to start we need: air fuel spark and COMPRESSION. Get your compression tested before you waist any more time and money , your engine being low comp you should get 120 to 150 psi the reading should be consistent on all 3 cylinders.
    If you only getting 90 psi your engine will still start but anything below 80 will be a struggle. Also how long has the engine been sitting ?
    Itís critical to remove salt water from intake and flush it with new liquid asap after water went in.
    Im talking hours not days!!!
    Good luck
    Dear @Zmilos

    Thanks for the quick reply,

    The jet had bewn sitting for almost a year,

    I will check compression and come back,

    How do I clean it now?

  4. #4
    Another item that gets damaged with water ingestion, especially saltwater, is the MAP sensor. Sounds like you also have residual water in the intake. Suggest you clean out all the intake, pressure check the intercooler, and replace the MAP sensor.

  5. #5
    Quote Originally Posted by Sea Dood View Post
    Another item that gets damaged with water ingestion, especially saltwater, is the MAP sensor. Sounds like you also have residual water in the intake. Suggest you clean out all the intake, pressure check the intercooler, and replace the MAP sensor.
    @Sea Dood,

    Thanks for the assist,
    I fitted a brand new intercooler, do I need to pressure wash it?
    Yes, there was some residue on the supercharger,

    I will look for the MAP Sensor,

    Regards,

  6. #6
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,750
    +1
    349
    Could also be bad gas, as ski has been sitting a year. It wouldn't hurt to drain the tank and add new gas

  7. #7
    WTemp_04's Avatar
    Join Date
    Aug 2019
    Location
    Lake Murray SC
    Posts
    21
    Im going to assume that It turns over considering you talked about doing a compression test. Test to see if the new plugs are even getting spark. If not maybe that a hint at a bad ignition coil? Anyone?

  8. #8
    Quote Originally Posted by moparguy View Post
    Could also be bad gas, as ski has been sitting a year. It wouldn't hurt to drain the tank and add new gas
    Hello moparguy,

    I took out all the old gas and added new one,
    Then Cleaned the injectors also, one of the first things I did,

    Regards,

  9. #9

    Join Date
    Sep 2010
    Location
    Floroeł, Norway
    Posts
    4
    Might want to do a compression test, I had same problem. Was stuck pistons rings.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2016 Seadoo Rxp 300
    By dewreck978 in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 09-05-2019, 09:13 AM
  2. FS 2016 Seadoo RXP-X 300 Low Hours
    By Dark Horse in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 10-28-2018, 07:00 PM
  3. SOLD 2016 Seadoo RXP 300
    By RXP85 in forum Sea Doo 4Tec Skis
    Replies: 4
    Last Post: 07-12-2017, 10:55 AM
  4. FS **2016 Seadoo RXP-X 300** SOLD
    By Jwall in forum Sea Doo 4Tec Skis
    Replies: 10
    Last Post: 04-04-2017, 08:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •