Results 1 to 5 of 5
  1. #1

    2002 Polaris virage 800 no start

    Iím new to owning a jets kit and bought a 2002 virage 800 with a crank no start problem. When the battery is hooked up gauges come alive even with lanyard installed. Had no spark so I installed a use emm and matching injectors. Now has spark but still wonít fire need help


  2. #2
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,052
    +1
    108
    Check the fuel pressure next. There should be a Schrader valve (tire stem in appearance) in the return fuel line. You should see 25 psi when cranking/running. You can obtain an affordable gauge here. If there is no fuel pressure, clamp off the return fuel line on the tank side of the Schrader valve and re-check. If it now reads near 30 psi, the fuel pressure regulator (FPR) has fallen off inside the fuel tank, which is very common. In fact, even if your fuel pressure readings are normal, you'll want to reinforce/repair the FPR ASAP. Often, the FPR falls off when running. When this occurs, the engine will continue to run, but with a very lean mixture that burns holes through pistons.

    You'll find more diagnostic/service info here and here.

  3. #3
    I got fuel pressure while cranking is it normal for the gauges to be on when the lanyard is not in

  4. #4
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,052
    +1
    108
    Quote Originally Posted by Jetskipete800 View Post
    I got fuel pressure while cranking is it normal for the gauges to be on when the lanyard is not in

    Yes

  5. #5
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,921
    +1
    227
    Quote Originally Posted by Jetskipete800 View Post
    I’m new to owning a jets kit and bought a 2002 virage 800 with a crank no start problem. When the battery is hooked up gauges come alive even with lanyard installed. Had no spark so I installed a use emm and matching injectors. Now has spark but still won’t fire need help
    Welcome to Greenhulk! Unless you know for sure that the second EMM is good, it's possible that BOTH EMMs are bad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Virage 800 No Spark Where Do you start?
    By PWCGUYWI in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-09-2019, 12:27 PM
  2. Polaris virage i 800 wont start 2002
    By Sutho in forum Polaris PWC Performance
    Replies: 9
    Last Post: 04-09-2017, 02:46 PM
  3. 2002 virage I 800 hard to start cold
    By 1200TXI in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 03-23-2017, 03:55 PM
  4. 2002 Polaris Virage 800 DI, wont start all time
    By rabiddawg in forum Polaris Tech Tips and Info
    Replies: 2
    Last Post: 08-08-2012, 02:59 PM
  5. 2002 Virage i 800 DI will not start
    By macdoo in forum Polaris Open Discussion
    Replies: 18
    Last Post: 04-03-2012, 06:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •