Results 1 to 3 of 3
  1. #1
    ian28's Avatar
    Join Date
    Aug 2018
    Location
    malta
    Posts
    12

    rxpx 255rs 2010 need help!!!!

    hi

    i have a rxpx 255rs when i put the key in the cluster will come on but no beep and on the cluster the hours will disappear and not cranking

    thanks

  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,622
    +1
    177
    Check the basics, battery fully charged and in good health, then connections, then fuses and clean dess post

  3. #3
    ian28's Avatar
    Join Date
    Aug 2018
    Location
    malta
    Posts
    12
    Quote Originally Posted by SplishSplash View Post
    Check the basics, battery fully charged and in good health, then connections, then fuses and clean dess post
    I checked every thing all good i think the ecu is the problem


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 RXP 255RS RPM Problems only around 7500rpm, not full power
    By tiptronic1812 in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-09-2016, 01:52 PM
  2. SOLD 2010 rxpx
    By akent in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 03-28-2016, 08:17 AM
  3. Raced a Seadoo RXP-255RS
    By Kayman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 01-27-2012, 10:54 PM
  4. RXTX 2010 or RXPX 2010
    By nmalfarhan in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-14-2011, 11:01 PM
  5. FS rxpx 2010
    By 270rxp in forum Sea Doo 4Tec Skis
    Replies: 1
    Last Post: 03-16-2010, 05:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •