Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Quote Originally Posted by Glenozzy View Post
    i just replace my this summer. none of it was left and i could not find any of it in the exhaust. I see blocking the exhaust as the only issue am i missing something?

    Mine lasted somewhere between the 50hr service and the 75hr service.

    It was jammed in the muffler even tho the ski was still running.
    Had to use one of those small flexible cameras to see it stuck in the muffler baffles.

  2. #12
    Spooling's Avatar
    Join Date
    Sep 2011
    Location
    West Coast of Florida
    Posts
    1,356
    +1
    191
    Quote Originally Posted by Glenozzy View Post
    I see blocking the exhaust as the only issue am i missing something?
    ------------------------------
    Here's a couple of older Threads for your reading pleasure:

    http://greenhulk.net/forums/showthread.php?t=223442

    http://greenhulk.net/forums/showthre...=1#post2432297

    It seems the early design filters were coming apart in a rather short amount of "run time". In the 1st thread - that guy was getting 10 hours out of them. Possibly the Re-Design by Kawasaki Engineering to the newer designed filter (hole in the center) promoted "some" better longevity.

    I fail to agree that after-ride care had anything to do with the longevity associated with the 1st designed filters (no hole in the center of the filter).

    What was happening was the filter would come apart, and if it managed to pass through the waterbox - it would "slice" the rubber exhaust hose while trying to exit the exhaust system - thus "choking" the engine from a smoke-filled engine bay OR "swamping" the engine bay with water - whichever came first.

    Good Luck !!!

  3. #13