Results 1 to 6 of 6
  1. #1

    Daughter's TRIXX loss of power and vibrating

    Long story short, my daughter's TRIXX was acting funny, more vibration than normal and only going about 45 not 53 @ WFO. She thought it was running out of gas. We pushed in onto the trailer (it had finally stalled) and when I filled it to put the fuel preservative in for the Winter, it only took 7.2 gallons and I stuffed it right to the top. This had me worried so when I ran it, on the trailer, to get the fuel preservative through the system, I decided to run it near the ramp for a bit. It wouldn't even hit 40 then it was down to 33 and vibrating. We have an appt. with the dealer and there isn't any damage to the prop. I looked. Any thoughts?

  2. #2
    quybb3,

    Have you checked the plastic wear ring to see if its broken or split in the pump?

    Thanks.

    Quote Originally Posted by guybb3 View Post
    Long story short, my daughter's TRIXX was acting funny, more vibration than normal and only going about 45 not 53 @ WFO. She thought it was running out of gas. We pushed in onto the trailer (it had finally stalled) and when I filled it to put the fuel preservative in for the Winter, it only took 7.2 gallons and I stuffed it right to the top. This had me worried so when I ran it, on the trailer, to get the fuel preservative through the system, I decided to run it near the ramp for a bit. It wouldn't even hit 40 then it was down to 33 and vibrating. We have an appt. with the dealer and there isn't any damage to the prop. I looked. Any thoughts?

  3. #3
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,803
    +1
    278
    Spark plugs?

  4. #4
    The wear ring looked fine from the shaft end. It's going to the dealer next week as its still under warranty. I will definitely let everyone know what's up when I find out.

  5. #5
    I saw a mess of leaves/pine needles in my daughter's TRIXX jet pump. The shaft side looked clean, the exhaust side when I hit the throttle and the reverse gate lifted up, not so much. That would explain her performance problems on the last ride.

  6. #6
    The dealer didn't find anything except the leaves, pine needles, and yes, a couple of twigs. So I think we are all set until Spring. Thanks for all your suggestions and help, Guys.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of 8 mph on TRIXX
    By guybb3 in forum Sea Doo Spark
    Replies: 8
    Last Post: 09-30-2019, 01:06 AM
  2. Loss of Power, Loss of oil, loss of coolant
    By Keatooon9988 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-02-2019, 06:12 AM
  3. Intermittent Loss of Power above 6000 RPM. Power Valves? - GP800R
    By mfabel in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-29-2015, 05:34 PM
  4. 2007 RXP oil loss/power loss
    By Mcr1994 in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-30-2013, 10:54 AM
  5. 3000 rpm..ENGINE VIBRATING, NO POWER AND STRIPPING SOUND.
    By jnash242 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 16
    Last Post: 07-09-2009, 04:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •