Results 1 to 7 of 7
  1. #1

    2004 polaris msx 150 no spark or fuel

    I own my automotive repair shop I work on jet skis every so often customer brought me an 04 polaris msx 150 he started it on the trailer to clean out the water motor revved to wide open he pulled the lanyard but it didnít shut off he cut all the wires to the kill switch and start button finally he in unhooked the battery and it shut off
    I installed a used kill switch plugged in the two connectors motor would crank but wouldnít start itís not waking up I have tested all fuses one 30 amp fuse doesnít have power tried jumping power to it no luck. I have done the bypass to sifb still nothing
    noticed he broke the main relay found the test for main relay it has power to pin 3 but no ground to 7 and 10 so I jumped ground to both pins fuel pump turns on still no spark would assume The fuel injectors are not working either because I couldnít smell any fuel
    I have had the battery charger on the battery while cranking.
    Anyone have any ideas? I have ordered a new main relay

  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,921
    +1
    227
    Welcome to Greenhulk!

    There's a good chance the SIFB is bad, it can be bypassed with a paper clip. LINK But be aware that you lose reverse RPM limit and it will likely rev to the moon when out of the water.

    Be sure the battery is good and strong, the ECU won't allow spark/fuel if the battery voltage drops below (circa) 10.8VDC.

  3. #3
    I have already done the bypass with the paper clip no change

    I will swap batteries tonight to see if anything changes

  4. #4
    Update
    replaced battery still same thing
    Question what color are the wires for the spend sensor and would anybody know the PIN numbers in the connector for the computer

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,818
    +1
    281
    Do these cut fuel and spark if they "see" an open throttle while trying to start like a Yamaha? Possibly a bad throttle cable/sensor/motor? That would explain it revving on him and not shutting off.

  6. #6
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,921
    +1
    227
    Quote Originally Posted by Crf45025 View Post
    Update
    replaced battery still same thing
    Question what color are the wires for the spend sensor and would anybody know the PIN numbers in the connector for the computer
    THIS information will be helpful.

  7. #7
    motokawa's Avatar
    Join Date
    Aug 2015
    Location
    Mirabel,quebec,canada
    Posts
    48
    +1
    1
    The ignition coils are control by the ecu


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 Polaris MSX 150 no spark no start ****Help****
    By spray&Splash2011 in forum MSX/Matrix
    Replies: 6
    Last Post: 08-01-2015, 06:05 AM
  2. 2004 Polaris MSX 150
    By ollison in forum MSX/Matrix
    Replies: 2
    Last Post: 07-19-2012, 04:58 PM
  3. FS 2004 polaris msx 150
    By MrRogue in forum Polaris Classifieds
    Replies: 5
    Last Post: 02-09-2012, 02:09 PM
  4. Replies: 0
    Last Post: 08-06-2011, 09:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •