Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    AlexFZR's Avatar
    Join Date
    Aug 2018
    Location
    Rome - Italy
    Posts
    86
    +1
    3

    My fzr sho won't run

    hi guys, i wanted to talk to you about a problem. maybe it's my impression. on my fzr sho 09 I have these changes:
    air filter, ribbon delete, waterbox riva, rear exhaust, breather filtee, solas 13 / 22R shortened to 13/19.
    The bike loses a lot in reach, about 4/5 Mph. At short it seems to work well, but after 55 mph it goes up very slowly.
    in some places, over short distances, it seems to be fine. But in length he dies. Then when the bike detaches from the water and picks it up, it can't pick up speed.
    Besides, it seems he doesn't have that violent shot I was expecting.
    my question is, do you think I was wrong to shorten the propeller? should I leave it with the original 13/22?
    Can a shortened propeller go back to the original pitch it had? In addition, the bike rises quickly, but remains "firm"

    my mechanic says that in order to optimize the work, you have to make an ECU, and see if the fuel pressure is right.

    Can anyone help?


  2. #2
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,291
    +1
    281
    Did these symptoms appear after doing the modifications? If so, then something went wrong with the installation. For example could be a loose clamp allowing boost to escape. Your mods are pretty basic and shouldn’t cause any of those issues. The prop isn’t the issue. I’d start with diagnosing the cause before changing the ECU. What are your RPMS?

  3. +1 by:


  4. #3
    AlexFZR's Avatar
    Join Date
    Aug 2018
    Location
    Rome - Italy
    Posts
    86
    +1
    3
    Quote Originally Posted by mikeFZR View Post
    Did these symptoms appear after doing the modifications? If so, then something went wrong with the installation. For example could be a loose clamp allowing boost to escape. Your mods are pretty basic and shouldn’t cause any of those issues. The prop isn’t the issue. I’d start with diagnosing the cause before changing the ECU. What are your RPMS?
    so for sure that the problem comes from the propeller. it's like he doesn't want to push. probably due to the excessively short wheelbase.
    this problem was born after changing the propeller and making it shorten from 13/22 to 13/19.
    As far as the engine revs are concerned, we are at 7400 7600. Starting from a standstill and giving gas suddenly, the speed rises quickly, but in comparison acceleration is nothing.
    Can you tell me what your stock is, what is the propeller of a fzr sho 09? because with that I noticed that I had a lot of reach, but little or nothing in acceleration. I'm interested in having acceleration, recovery, and a good stretch.
    before I reached 72/73 Mph, now I reach 66/67 Mph.
    You can't stand next to me a gp1200


  5. #4
    AlexFZR's Avatar
    Join Date
    Aug 2018
    Location
    Rome - Italy
    Posts
    86
    +1
    3
    Quote Originally Posted by mikeFZR View Post
    Did these symptoms appear after doing the modifications? If so, then something went wrong with the installation. For example could be a loose clamp allowing boost to escape. Your mods are pretty basic and shouldn’t cause any of those issues. The prop isn’t the issue. I’d start with diagnosing the cause before changing the ECU. What are your RPMS?
    in the diagnosis everything is ok

  6. #5

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,374
    +1
    93
    DoNt think you will run a 13/19 pitch without a tune, with the mods you have 13/22 would be ideal. I’m running similar mods on fx sho but 13/22 solas.

    ribbon delete, filter, exhaust, (stock waterbox, and tune)

  7. +1 by:


  8. #6
    AlexFZR's Avatar
    Join Date
    Aug 2018
    Location
    Rome - Italy
    Posts
    86
    +1
    3
    Many thanks i keep in mind!
    Quote Originally Posted by HDAV View Post
    DoNt think you will run a 13/19 pitch without a tune, with the mods you have 13/22 would be ideal. I’m running similar mods on fx sho but 13/22 solas.

    ribbon delete, filter, exhaust, (stock waterbox, and tune)

  9. #7
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,291
    +1
    281
    Each brand of props is different so a 13/19 Skat will performance different than a 13/19 Solas or 13/19 stock prop. You want your WOT RPMS to be right at 7700 with the stock ECU. When you are at WOT take the rear seat off and if you hear a “popping” sound, that is the soft rpm limited shutting down the #1 cylinder. That would mean you want to increase the pitch of the trailing edge (maybe up to a 21). I have similar mods and really like the Skat 13/20, but the Solas you have is definitely more than sufficient.

  10. +1 by:


  11. #8

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,374
    +1
    93
    Is that done on trailer or on water cause I can’t here sheeeeet at wot on the water,,..l

  12. #9
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,563
    +1
    212
    On the water
    Maybe get a friend to listen from shore
    It’s quite obvious when you are not on the ski

  13. #10
    AlexFZR's Avatar
    Join Date
    Aug 2018
    Location
    Rome - Italy
    Posts
    86
    +1
    3
    Quote Originally Posted by mikeFZR View Post
    Each brand of props is different so a 13/19 Skat will performance different than a 13/19 Solas or 13/19 stock prop. You want your WOT RPMS to be right at 7700 with the stock ECU. When you are at WOT take the rear seat off and if you hear a “popping” sound, that is the soft rpm limited shutting down the #1 cylinder. That would mean you want to increase the pitch of the trailing edge (maybe up to a 21). I have similar mods and really like the Skat 13/20, but the Solas you have is definitely more than sufficient.
    difficult decision. What I can tell you, having tried it in the water, "crackling" all the time I hear only the rear exhaust. I didn't try to remove the saddle and feel. but the feeling is that the bike does not have the "blow" of the original propeller. My mechanic says that 13/22 is too long, with 13/19 it's too short. the right choice would be a 13/20 or a 13/21

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2013 Yamaha sho fzr won't crank??
    By sevon in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 05-22-2014, 12:30 PM
  2. 2012 FX Cruiser SHO won't run right until hot
    By poplawchuk in forum Yamaha PWC Performance (4-stroke)
    Replies: 19
    Last Post: 05-22-2014, 12:13 PM
  3. 02 Virage still won't run!
    By Rachel in forum Polaris Open Discussion
    Replies: 18
    Last Post: 08-07-2012, 12:43 PM
  4. SL 750 won't run over 20
    By MAS in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-23-2008, 02:48 PM
  5. She won't run
    By kschally in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-12-2008, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •