Results 1 to 2 of 2
  1. #1

    720 Cooling System Help

    I'm going through my 98 Sportster 1800 trying to fix all the stuff the PO screwed up. Some of the stuff I have no reference as to if it's correct or not. Generally I'm able to use the shop manual to figure out what has been modified but I've also found a few instances in the shop manual where the info was correct for ski's that used my engines but incorrect for the boats the manual is printed for. (Obviously, SeaDoo cut and pasted when they shouldn't have.) This may be one of those cases but I need people who know to verify for me.




    This picture is from the manual but I have added the orange line at the bottom. The manual only shows the red line as the correct factory setup. But my system has a second tee-fitting with a line going to a port in the pump approximately where I have shown with the orange circle. Is this orange line supposed to be there or is it something the PO has added?


    Also, I have the lines going to behind the tow hook, but no visible ports on the hook itself. I noticed the hook is raised off the actual surface using a washer. Does the indicator water just leak out from the small space behind there? I have no piss of water shooting in the air like skis have ...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	cooling.png 
Views:	40 
Size:	116.9 KB 
ID:	454826  

  2. #2
    Just found tyhis in the parts manual:



    That is how mine is plumbed so I guess it's right.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I need someone!!! My cooling system......
    By Sparkmiester in forum Sea Doo Spark
    Replies: 4
    Last Post: 08-01-2014, 11:21 PM
  2. Cooling System
    By Susquehanna Skier in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 03-02-2009, 10:07 PM
  3. 99xl1200 cooling system
    By bbealing in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-25-2008, 09:09 PM
  4. How do I know if the cooling system is working
    By utahnewbie in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-31-2007, 09:42 AM
  5. Cooling system ?
    By mattman in forum Polaris PWC Performance
    Replies: 6
    Last Post: 04-22-2007, 01:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •