Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,823
    +1
    654
    Took the 'Skis out on our lake today, they performed perfectly.

    Do these things have a thermostat?


  2. #12
    Iím confused. What fixed the problem?

  3. #13
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,823
    +1
    654
    Quote Originally Posted by blakegjones View Post
    I’m confused. What fixed the problem?
    I don't know. I was never able to find any blockage. My guess would be something like a small stick that dried out, shrank, and came loose.

    I did blow gently back through the pisser (by mouth) and had little resistance.

  4. #14
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,768
    +1
    357
    Quote Originally Posted by steve45 View Post
    I did blow gently back through the pisser (by mouth) and had little resistance.
    I know we are all friends here but maybe don't mention that outside of the forum...

    Sean

  5. #15
    Quote Originally Posted by smokeysevin View Post
    I know we are all friends here but maybe don't mention that outside of the forum...

    Sean
    Haha!

    Anyways glad itís sorted. Really is strange though. No thermostat that Iím aware of. Only part of cooling system I havenít opened up is in the oil cooler and doubt there is one In there.

  6. #16

    Join Date
    Mar 2010
    Location
    Long Island, NY
    Posts
    830
    +1
    69
    You'd get a lot of resistance if you tried to blow through my pisser.

  7. #17
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,823
    +1
    654
    OK, ha, ha, ha!

    I was just following Blake's advice.

    I couldn't find any reference to a thermostat, but Yamaha uses them on some of their 4-strokes.

  8. #18

    Join Date
    Mar 2010
    Location
    Long Island, NY
    Posts
    830
    +1
    69
    There is no thermostat on the Kawi motors. But you are correct, the Yamaha MR-1 motors do have a thermostat.

    Check the brass fittings on the waterbox. The openings are very small, and can easily be blocked by debris.

  9. #19
    Quote Originally Posted by grumpy_steven View Post


    Check the brass fittings on the waterbox. The openings are very small, and can easily be blocked by debris.
    Yes that is very true. I swopped that brass fitting on the waterbox with the tiny orifice with a connector that has a slightly bigger diameter and used a hose with a smaller ID to add to the pressure loss that I removed by swopping out the small orifice.

    I found bits in that small orifice every single time I looked at it which is what made me change it out.

  10. #20
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,823
    +1
    654
    Thanks, Blake! I'll take a look at it.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ď07 Kawasaki Ultra 250x Overheating
    By BillyBennett in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 08-01-2019, 05:12 PM
  2. Ultra LX Overheating HELP
    By Dangerous in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 05-03-2016, 09:30 PM
  3. 07 Kawasaki Ultra LX overheating
    By phonebooth in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 03-17-2016, 05:01 PM
  4. 07 Kawasaki Ultra LX overheating
    By phonebooth in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 03-12-2016, 06:52 AM
  5. Ultra 150 overheating
    By seasalado in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 07-09-2012, 12:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •