Results 1 to 10 of 10
  1. #1

    2009 Ultra 260x idle ok, restricts at 3k for wot then stalls once throttle released

    Hi guys,

    Hoping to be pointed in the right direction to isolate the issue a bit and pin point what is happening here. I am sure someone has had this issue occur at some stage for their ski.

    On the water (fresh water, well a massive dam) the ski starts and idles okay. Pulling the throttle on up to 2.5k there is no issue but once you get to 3k, it wont go any further and starts coughing. If I go WOT at this point for say 5 seconds and then dump off the throttle, the ski stalls. I performed this test 3 times to make sure it was consistent. When I go to restart the ski, it goes to start then stalls immediately about 2-3 times before it starts like normal again.

    I am thinking that it is fuel related where when performing WOT, i am loading up the fuel and then when i release the throttle, the ski stalls. When i start it back up and it keeps stalling, its like a car that gets flooded.

    Thoughts?


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,626
    +1
    772
    Supercharger belt?

  3. #3
    Supercharger belt is okay and firmly tight.

    If the supercharger rod was snapped inside the supercharger, would that cause no boost and all the symptoms described above?

    One would assume that the ski would perform like the yellow key where the supercharger is not active but still runs normal, just without boost.

  4. #4
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,626
    +1
    772
    Doesn't work like that on these skis.

  5. #5
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,626
    +1
    772
    It's still dumping fuel thinking the charger is working correctly, just being tight doesn't make it right, it needs to be set to a gauge.

  6. #6
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,774
    +1
    359
    It wouldnt hurt to pull the belt and spin the charger by hand. Make sure its not dragging. The 250/60s really need the proper tool to get the belt tension correct.

    Sean

  7. #7
    Ill perform that test Sean!

  8. #8
    Fouled plugs will cause symptoms like that. You can low rpm yourself back to dock, but if you try to get on it, it'll bang out and or die.

  9. #9
    My Jet Ski drinks more than yours Glenozzy's Avatar
    Join Date
    Apr 2008
    Location
    SML, VA
    Posts
    852
    +1
    18
    same problem last month had a bad plug
    #1 stop working when it hit 30 mph boat stared to shake
    i was sure it was the super charger I could not find anything wrong final took it to the dealer
    the changed the plugs and water tested it.
    gave it back to me i water tested it and it was running great
    so try changing the plugs

  10. #10
    OK!

    So took it to a mechanic and the issue was the supercharger rod was snapped

    $3.5K to get it fixed which is 50% of the value of the ski

    I will get it replaced and sell the damn thing as it has just been a money pit.

    Purchased for $10k AUD and owned it for 6 years. It has cost me all up $20k and ill end up selling it for $6k.

    $2.3k per year to own the ski plus running and registration costs. Time to get a toy that is more reliable! Harley Breakout!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki Ultra 260X 2009 - Stuck throttle ?
    By martincarrier4 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-05-2014, 02:06 AM
  2. Ultra 260x Stalls
    By Norway in forum Open Discussion
    Replies: 1
    Last Post: 07-14-2013, 12:08 PM
  3. 94 SL 750 Stalls going from Idle to WOT
    By RA_Crash in forum Polaris Open Discussion
    Replies: 34
    Last Post: 07-18-2012, 10:20 AM
  4. STX15f stalls coming off throttle and won't idle warm
    By carguy89 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-05-2011, 10:06 AM
  5. 2001 zxi 1100 stalls when you hit the throttle more than 1/2 way from an idle
    By offroadinjersey in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-10-2009, 11:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •