Results 1 to 3 of 3
  1. #1

    1994 GTX can't get past 33mph

    I am having issues with our wave runner. It starts, idles, and accelerates fine. However, once we hit about 33mph, the revs start to go up and down and it won't go any faster, in fact it starts to slow down to about 20mph, and then the revs will start climbing up to about 33mph again. We have checked for loose hoses and tightened a couple connections, checked the carbs, and they look clean. There is some water getting in the engine compartment, not a lot, but some. We start it on the trailer and it revs with no issue, and hit the throttle and the revs go up just fine. I haven't gone full throttle on the trailer, but it doesn't hesitate to rev up as far as I am willing to take it. When we get on the water, it has very good acceleration out of the hole, and flies up to 33 mph, but then the revs start going up and down once it hits that speed, and that is as fast as we can get it going. If we hold the throttle, all the revs do is pulse and not let the ski go any faster. Can anyone help us out?

    I will add, there was a hose loose between the muffler and engine exhaust. It came off the engine side of the pipe, and there was water and oil inside the engine compartment. We drained the water and cleaned up the engine bay as best we could. We re-attached that and there doesn't seem to be any effects from that. We also replace the throttle cable after the issues started, as it had snapped on us in between the issues starting and now, but that has not changed anything. It still revs exactly the same at idle and accelerates the same as it did before the issues started . We just can't get the top end back.
    Last edited by cast96; 09-11-2019 at 11:44 PM.


  2. #2
    Hurricane1000's Avatar
    Join Date
    Oct 2005
    Location
    Gulf of Mexico
    Posts
    1,052
    +1
    108
    Either a clogged filter inside the carburetor easy to clean....

    The fuel baffle could be leaking due to a cracked fuel pickup.
    If turning the reserve valve helps....that is the problem.
    Common issue for that ski.

  3. #3
    Quote Originally Posted by Hurricane1000 View Post
    Either a clogged filter inside the carburetor easy to clean....

    The fuel baffle could be leaking due to a cracked fuel pickup.
    If turning the reserve valve helps....that is the problem.
    Common issue for that ski.
    I am assuming you mean turn the fuel knob to reserve instead of to on. We will give that shot. Thank you for the advice

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. More GTX rfi questions... will not rev past 6000 and shuts down
    By zrtman in forum 2-Stroke Performance
    Replies: 7
    Last Post: 04-16-2018, 12:53 PM
  2. 99 GTX won't rev past 6200
    By Bryanford in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-10-2016, 10:58 AM
  3. 2006 GTX Limited 215 - wont throttle up past 20mph...
    By surfcitypops in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-26-2014, 03:23 PM
  4. 1996 Seadoo GTX won't run past 5500rpm
    By not2fast in forum 2-Stroke Performance
    Replies: 10
    Last Post: 08-26-2014, 01:26 PM
  5. 1994 GTX
    By MKA in forum 2-Stroke Performance
    Replies: 5
    Last Post: 04-24-2010, 10:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •