Results 1 to 4 of 4
  1. #1

    Join Date
    Oct 2018
    Location
    Usa
    Posts
    397
    +1
    8

    Seadoo engine would accelerate beyond 3000 rpms

    I have a friend with a Large seadoo challenger wake, that is having issues with 1 of the 2 engines which it won't accelerate beyond 3000 Rpms. He pulled the pump and its all clear of debris, driveshaft is also aligned. It runs perfectly on the hose though but seems to have issues under load. Any guesses? Its a 2007. Thank you.

  2. #2
    gone fishing sucks2bu's Avatar
    Join Date
    Sep 2013
    Location
    miami fl.
    Posts
    553
    +1
    28
    Is he getting any codes? Sounds like maybe a sensor is throwing that engine into limp home mode. Usually an oil sensor or temp sensor.

  3. #3
    gone fishing sucks2bu's Avatar
    Join Date
    Sep 2013
    Location
    miami fl.
    Posts
    553
    +1
    28
    Check sensor connections for any signs of oxidation, check the bus bars grounds and positives for oxidation. Check the grounds on that engine/clean and tighten. Pain in the arse to do on a boat but hey,,, pay to play.

  4. #4
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,929
    +1
    234
    Try the obvious, change spark plugs.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 seadoo rxp will not accelerate on water
    By alex1988 in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-12-2018, 08:00 PM
  2. Replies: 0
    Last Post: 04-19-2015, 07:06 PM
  3. Did my seadoo just accelerate on its own?? YIKES
    By Mrgooger99 in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-23-2014, 04:06 PM
  4. Replies: 2
    Last Post: 07-06-2013, 10:20 AM
  5. Replies: 2
    Last Post: 05-07-2011, 03:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •