Results 1 to 1 of 1
  1. #1

    missing diaphragm body assembly in SBN 38

    Hello all, I have a 1995 Yamaha Waveraider 1100 engine that I put into a jet jon. I got to test it out twice and it has not ran right and idles rough. I've been adjusting the mixture screws and I got it to where I can use up to 1/8 throttle and then it dies if I go any further. If I go WOT it will accelerate quickly for 15 seconds and then die. Before I tested it in the water, I checked the compression (125psi on all 3), rebuilt the carbs , new plugs, used fresh gas mixed 40:1, replaced fuel pump with mikuini hi flow.
    My question is, in the service manual it shows a diaphragm body assembly on each carb. Mine doesn't have that. Is that a problem or is it normal? #24 is the body diaphragm that's missing.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screenshot_20190911-085501.jpg 
Views:	27 
Size:	225.8 KB 
ID:	453662  


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 951 carb question on ?missing? parts (diaphragm question)
    By macGruber in forum 2-Stroke Performance
    Replies: 8
    Last Post: 08-27-2013, 08:25 PM
  2. different type of Mikuni SBN 44 / I body???
    By waterworld in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 02-10-2011, 11:56 AM
  3. Mikuni SBN Fuel Diaphragm Test...
    By 1996SLTX in forum 2-Stroke Performance
    Replies: 7
    Last Post: 11-24-2007, 08:31 PM
  4. Mikuni SBN Fuel Diaphragm Test...
    By 1996SLTX in forum Polaris Open Discussion
    Replies: 8
    Last Post: 11-24-2007, 12:52 PM
  5. Carbs I-body vs SBN
    By OsideBill in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 10-18-2007, 11:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •