Page 1 of 2 12 LastLast
Results 1 to 10 of 37

Hybrid View

  1. #1

    New 2019 TX engine blow with 10hrs

    anybody has this problem with the new engine..my engine blow (lock) at 10.7hrs..i check for damage and i see the number 1 piston is destroy..one of the valve broke in pieces leaving the engine lock....anybody with this issue??


  2. #2
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    3,067
    +1
    215
    Quote Originally Posted by Emol:TX View Post
    anybody has this problem with the new engine..my engine blow (lock) at 10.7hrs..i check for damage and i see the number 1 piston is destroy..one of the valve broke in pieces leaving the engine lock....anybody with this issue??
    Maybe a bad batch on some 2018/19 because same thing happened to a few of my friend in diff states .
    Click image for larger version. 

Name:	IMG_3534.jpg 
Views:	153 
Size:	59.5 KB 
ID:	453612Click image for larger version. 

Name:	IMG_3535.jpg 
Views:	147 
Size:	52.3 KB 
ID:	453611

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    9,173
    +1
    1,530
    Quote Originally Posted by DR2006RXP View Post
    Maybe a bad batch on some 2018/19 because same thing happened to a few of my friend in diff states .
    Click image for larger version. 

Name:	IMG_3534.jpg 
Views:	153 
Size:	59.5 KB 
ID:	453612Click image for larger version. 

Name:	IMG_3535.jpg 
Views:	147 
Size:	52.3 KB 
ID:	453611
    Ouch!

  4. #4
    yeap..mine blew off a valve just like that..

  5. #5
    What mods were done to it?

  6. #6
    Did the springs bind? The most likely scenario is something caused the valve to stick and it made contact with the piston.

  7. #7

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    374
    +1
    34
    Quote Originally Posted by Emol:TX View Post
    anybody has this problem with the new engine..my engine blow (lock) at 10.7hrs..i check for damage and i see the number 1 piston is destroy..one of the valve broke in pieces leaving the engine lock....anybody with this issue??
    What did your dealer say?

  8. #8
    I'm really curious what would cause this to happen to a dozen engines and only on #1cylinder. I wonder if their is a problem with the cam profile on this lobe. Maybe the problem makes the intake valve float at high rpm.

  9. #9
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,680
    +1
    204
    Quote Originally Posted by truck240 View Post
    I'm really curious what would cause this to happen to a dozen engines and only on #1cylinder. I wonder if their is a problem with the cam profile on this lobe. Maybe the problem makes the intake valve float at high rpm.
    The cam part # changed for the 18’s and haven’t heard of any valve issues on them yet. ��

  10. #10
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    8,590
    +1
    557
    Quote Originally Posted by psycho rxp View Post
    The cam part # changed for the 18ís and havenít heard of any valve issues on them yet. ��
    Seems like only 19ís with these type of failures from what Iím gathering.

  11. +1 by:


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 6 users browsing this thread. (4 members and 2 guests)

  1. Fixnfly,
  2. Gocman,
  3. jeel,
  4. Team Bilford

Similar Threads

  1. Will my engine blow?
    By Vinicius in forum 4-Tec Performance
    Replies: 21
    Last Post: 03-11-2016, 09:10 AM
  2. Ultra 260x Engine problem 2009. Blow engine ?
    By Kawa260x2009 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-03-2015, 09:55 AM
  3. Engine Blow
    By jetskibrian in forum GreenHook.net PWC Fishing
    Replies: 3
    Last Post: 05-02-2015, 09:51 AM
  4. How much water does it take to blow an engine?
    By cjo632racing in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-15-2011, 10:24 AM
  5. Engine blow up.
    By jetskidj in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 03-13-2007, 09:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •