Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 37
  1. #21
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    3,075
    +1
    215
    Quote Originally Posted by BMist371 View Post
    Has anyone with a 2019 with upgraded springs and retainers dropped a valve yet? Or just stock skis?
    Iíve seen (2) 2019 with springs and retainers drop a valve in #1 cylinder .

  2. #22
    Im out of reasonably simple fixes then. Sounds like a new cam profile must be the issue if springs and retainers aren't helping it. Hard to imagine that a simple valve alone could do that. This is going to be nerve racking going forward.

  3. #23
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,681
    +1
    204
    Quote Originally Posted by BMist371 View Post
    Im out of reasonably simple fixes then. Sounds like a new cam profile must be the issue if springs and retainers aren't helping it. Hard to imagine that a simple valve alone could do that. This is going to be nerve racking going forward.
    They changed the cam part number in 2018, and now in 2019 they changed the intake valve part numbers. Since it’s only the 19’s with the issues so far, I would say it’s more towards the new valves material or Quality , thats the issue.

  4. +1 by:


  5. #24

    Join Date
    Oct 2018
    Location
    Usa
    Posts
    423
    +1
    8
    Warranty??

  6. #25
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,981
    +1
    4
    Just got a 2019 RXT-X 300 and so excited...wait, what? Engines destroyed in short time? I’ll be watching this thread and my ski as the hours tick up. I’m more worried about downtime than warranty coverage. I wonder if there’s a correlation with HIN units as if someone on the assembly line was having a bad day?

  7. #26
    I wonder if we get a recall, if I buy some supertech valves, they'll throw them in for me for free.....The dealer could have a free set of factory 300 valves....

  8. #27
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,981
    +1
    4
    This is a lot like WebMD where you think something is wrong and you look online and it's terminal. Except I'm not finding information elsewhere about this issue other than this site. Someone on this thread said he did some digging and found 12 units had this same issue. What has been the outcome of those with these issues? I assume everyone is going after BRP to fix as they're all 2019 models and under factory warranty. I'm just looking for more information. I read a lot of people are proactively dumping about a grand into their new units based on this information when I haven't heard the rest of the story from the shop or BRP.

    Anyone have more information or what has happened since it's been in the shop and a decision to cover under warranty was or wasn't made?

    Thanks!

  9. #28
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,545
    +1
    212
    If it was wide spread I think there would be a lot more posts on it
    Might be just a few bad valves
    Seems odd that itís the same valve in the same cylinder though

  10. #29

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    374
    +1
    34
    Quote Originally Posted by rx4pain View Post
    This is a lot like WebMD where you think something is wrong and you look online and it's terminal. Except I'm not finding information elsewhere about this issue other than this site. Someone on this thread said he did some digging and found 12 units had this same issue. What has been the outcome of those with these issues? I assume everyone is going after BRP to fix as they're all 2019 models and under factory warranty. I'm just looking for more information. I read a lot of people are proactively dumping about a grand into their new units based on this information when I haven't heard the rest of the story from the shop or BRP.

    Anyone have more information or what has happened since it's been in the shop and a decision to cover under warranty was or wasn't made?

    Thanks!
    What baffles me is people say they blow an engine at 10 hours then come to an internet forum for answers insteade of going to the dealer for warranty? Name of selling dealer is never mentioned, so no way to verify the bogus claims

  11. +1 by:


  12. #30
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,681
    +1
    204
    Quote Originally Posted by fx160 View Post
    If it was wide spread I think there would be a lot more posts on it
    Might be just a few bad valves
    Seems odd that it’s the same valve in the same cylinder though
    In my case, it’s not the same cylinder , it was the middle cylinder with the issue. It is currently at the dealer, still waiting to be taken apart and diagnosed. I think the problem is most are still at the dealers waiting for them to be looked at, or approved by warranty, seeing as it’s still summer here in Florida, i’m at the mercy of the dealer.

    Mine has been at the dealer 12 days Now , and it still hasn’t been torn apart yet.
    I know of one case posted on the Seadoo 300 enthusiasts page on Facebook, that finally got their warranty motor approved, and was waiting for Seadoo to ship it from Canada ( through customs), then to the dealer for install. As you can imagine the motors were back ordered for some time before being shipped. I’m sure we’ll see more posts on these as they Get finished and back on the water.

    Here was his post.

    Click image for larger version. 

Name:	8ACA5F18-905C-4C5B-8898-E535EBCDFF94.jpg 
Views:	91 
Size:	297.1 KB 
ID:	454029


Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Will my engine blow?
    By Vinicius in forum 4-Tec Performance
    Replies: 21
    Last Post: 03-11-2016, 09:10 AM
  2. Ultra 260x Engine problem 2009. Blow engine ?
    By Kawa260x2009 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-03-2015, 09:55 AM
  3. Engine Blow
    By jetskibrian in forum GreenHook.net PWC Fishing
    Replies: 3
    Last Post: 05-02-2015, 09:51 AM
  4. How much water does it take to blow an engine?
    By cjo632racing in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-15-2011, 10:24 AM
  5. Engine blow up.
    By jetskidj in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 03-13-2007, 09:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •