Results 1 to 3 of 3
  1. #1

    Angry I think the dealer broke my sponson before delivery, what should I do?

    So I got my 310x on 8/19 and I've put it in the water exactly 3 times. I have not hit anything, followed proper break-in, fully flushing engine/intercooler, washing it, fogging the SC, etc... I've treated it like a child since it's not exactly a small purchase for me. I was installing some trailer guides on my trailer to make it easier to see the trailer when the ski is not on it (retrieving at the launch). It has not floated around, bottomed out been otherwise mishandled. When I was laying on the ground getting some of the trailer guide bolts in, I looked up as saw the starboard sponson. I did not notice it standing up. I was wracking my brain how a hole could have been put in the sponson right on the front and I didn't notice hitting anything. And then it occured to me, this seems more like damage that would occur if the sponson rolled and hit pavement. I am 99% certain this happened at the dealer before I took delivery and nobody noticed.



    So, how should I proceed here? Will the dealer tell me to f**k off? Has anyone else experienced this? Should I just buy a new sponson and be done with it?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_2797.jpg 
Views:	89 
Size:	52.5 KB 
ID:	453486   Click image for larger version. 

Name:	IMG_2798.jpg 
Views:	89 
Size:	50.6 KB 
ID:	453487  


  2. #2
    That's kinda what I figured. I can just buy a new one for $53. Any chance you'd know how I find the torque settings for those bolts?

  3. #3
    Hurricane1000's Avatar
    Join Date
    Oct 2005
    Location
    Gulf of Mexico
    Posts
    1,053
    +1
    108
    That's what I would do....
    Save your relationship with your dealer....
    You might need it down the road......
    Pistons?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 virage still broke, and going to go broke repairing it
    By elk river rascal in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-02-2013, 09:36 AM
  2. Dealer Set Up and Delivery Costs
    By David_HX_RXP in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 02-15-2013, 12:59 PM
  3. Help! Broke a Sponson Adapter
    By FullTilt429 in forum 4-Tec Performance
    Replies: 5
    Last Post: 02-16-2011, 11:37 PM
  4. Delivery Time!
    By christian gpr in forum HSR-Benelli - Hydrospace PWC
    Replies: 1
    Last Post: 11-23-2008, 04:43 PM
  5. Delivery!!!!
    By steach in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-13-2007, 07:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •