Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40
  1. #1
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    683
    +1
    33

    2019 BRP owners MUST READ...CRITICAL....AND EVERYONE ELSE FOR THAT MATTER

    OK so here it goes...bought a brand new 19 Rxp-300 and began the break in process. At 7 hours i began to give it the odd shot of wot and found that it had quite a vibration so I didnt want to wreck anything so took it back to the shop for a good tear down to see what was up.
    Here is what i found....to begin...once i got a few hoses out of the way i noticed a black line of carbon ring dust that is usually a small amount under the drive line boot and upon visual noticed the frigin boot was literally cut off...yes the flap that is designed to cover the carbon ring was what looked like cut with a razor knife. I have many times been frustrated when trying to get the supercharger in...this piece of rubber is annoying and i normally just get it wet just prior to supercharger install and that aids in sliding/squeezing the charger over this flap...but upon assembly these guys just cut the friggin thing off....how do i no this is true...well now this is the 3rd ski (2019 300 platform) that i have seen with this same scenario...absolutely brutal...but it doesnt stop there. After digging around I did find the cut piece of flap in the bottom of the hull as you will see in the pics.
    2) ok so now i tear everything out and get my alignment tool out and low and behold the engine from the assembly plant had NEVER been aligned and is sooooo far out you wouldnt believe it. NO SHIMS UNDER ENGINE MOUNTS AT ALL... NOT 1..once again i reference all my other 300's and all the 2016/17 models have shims...my 2018 had none but that's a whole other story as it had a bent drive shaft from brand new that got warranty when it was new so that engine was properly aligned after the new shaft was installed...i didnt think much of it at the time but now realize this is likely a 2018 issue as well but i can say my 2018 DIDNT have the pto bello sliced...which is a good thing.

    so what does this mean? ...all you guys with 2019 models check your driveline pto rubbers as im betting they are cut and you will find the flap that was cut in the bottom...also check the engine mounts and see if there are ANY SHIMS under the mounts...if not the engine is WAY out of alignment guaranteed!!!...i will post pics and you can be the judge....I have looked at and talked to 2 others that have the same issue ....EXACTLY the same as mine....SO BEWARE...and if you find what I have found CALL BRP and let them know ....if you don't have problems now you WILL down the road with the engine this far out of alignment. My carbon ring was incredibly worn and my boat only; has 7 hours on it....here are pics


  2. #2
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    683
    +1
    33
    tried to copy and paste pics....you can see how far out this crap is...im still in shock
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	brp1.jpg 
Views:	390 
Size:	52.0 KB 
ID:	453227   Click image for larger version. 

Name:	brp4.jpg 
Views:	275 
Size:	46.4 KB 
ID:	453228   Click image for larger version. 

Name:	brp2.jpg 
Views:	264 
Size:	33.4 KB 
ID:	453229   Click image for larger version. 

Name:	brp5.jpg 
Views:	263 
Size:	55.0 KB 
ID:	453230   Click image for larger version. 

Name:	brp6.jpg 
Views:	259 
Size:	52.6 KB 
ID:	453231  

  3. #3
    Banned User
    Join Date
    Jun 2007
    Location
    My House
    Posts
    4,108
    +1
    335
    your right about it being so tight on charger install as i found out when i did my 300 charger conversion....i cut my own flap off I got so tired of F*CKIN with mine...BUT for the FACTORY to be doing this is & then just throwing them inside the hulls is F*CKING insane...PERIOD!!!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC02771.jpg 
Views:	197 
Size:	85.2 KB 
ID:	453232  
    Last edited by REID2168; 08-29-2019 at 10:36 PM.

  4. #4
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,438
    +1
    345
    That’s some bullshit for sure. Can’t say I’m surprised though, have seen some pretty bad alignment issues also. The cut flap is a new one on me though...

    This crap is getting ridiculous.

    Thanks for posting this.

  5. +1 by:


  6. #5

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,041
    +1
    166
    Have you ridden the ski since you aligned the engine? Is the vibration gone? How was the longitudinal position of the engine-did you have to push it forward? You're lucky that you have the tools and skills to do this yourself since I don't think there are many dealer techs that are able.

  7. #6
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    683
    +1
    33
    Reid...in order to get the charger in smoothly if you remove the pump and push the driveshaft over it will go in much easier

  8. #7
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    683
    +1
    33
    i am still waiting for parts...BUT ...same thing on my 2018 and once i installed correct shims....bingo...super smooth and the way it should have been from factory. When I did the 2018 it had 20 hours on it and had dam near wore out the carbon ring on the bottom...it was UNREAL

  9. #8

    Join Date
    Sep 2014
    Location
    Southern middle TN
    Posts
    491
    +1
    267
    just reading this makes me furious. i don't know how i would be able to hold back if i had paid that much and then find it done blatantly wrong.

    what did BRP says?

  10. #9
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    683
    +1
    33
    well they really just opened a case file for me on my machine. IF i had not noticed and have knowledge on how this is to have been done right it may take hours and hours for this to show up ...that said...my carbon ring was worn badly after only 7 hours of breakin so i expect that the average person may not see anything until 50-75 hours...quite possibly more. I WILL SAY THO...the vibration from engine alignment again to the average guy may seem quite normal...to me it seemed quite accessive only because i have owned now 12 separate units since 2012 or the conception of the t3 hull and KNOW from experience that this vibration was excessive. I am as furious as all you guys however PLEASE don't take this out on your dealer ....this is a assembly/manufacturer issue ...call the BRP hotline and inform them if you are an effected owner...and work with your dealer to correct the issue

  11. #10

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,041
    +1
    166
    There's some very weird things going on here. Why would someone on the assembly line cut the PTO shroud? This alignment issue is driving me nuts...I got ONE ride out of a carbon ring that a dealer tech installed on my RXT. I then had a competent indy tech replace the ring and align the engine again and the ring still started wearing immediately.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XLT owners please read
    By WATER WOODY in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 04-03-2010, 12:55 AM
  2. New Kawasaki Owners, Please Read first
    By Hydrotoys in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 04-16-2009, 10:12 AM
  3. New Kawasaki Owners, Please Read first
    By Hydrotoys in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 04-16-2009, 10:12 AM
  4. Madien Voyage.. PX OWNERS please read
    By seadooingfreak in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-11-2008, 04:10 AM
  5. Does BRP read this stuff?
    By RiverRacerX in forum Sea Doo Sport Boats
    Replies: 9
    Last Post: 07-17-2007, 11:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •