Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Msxslayer's Avatar
    Join Date
    May 2019
    Location
    canada
    Posts
    195
    +1
    2

    Wear omg question

    Msx 140. Stainless wear ring
    I ordered a oem prop same prop number
    Took old one out
    Try to put new one in. It is so tight
    Had to use a wire wheel
    And my clynder honer to get it round and wider
    I can push the blade through the ring by hand now. But canít get it to turn fully yet. When I put it on the stator and ring over the impeller and put the tool on and impact gun. It starts to turn but binds out. But is better then It was
    Anyone else have this Problem

    Wear ring question not wear omg
    Not sure how to fix that lol

  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,869
    +1
    2,094
    New impeller does not fit into the new wear ring, correct?

    Wear ring came from what source?

    Impeller is actually new, or good used, or refurbished?

    This is with the pump out of the hull, just sliding the new wear ring over the new impeller? Try that first, before trying the fit with everything pushed into the transom.

    Also make sure there is no gunk build up around the rim of the pump stator where it mates with the wear ring. The two sections must mate metal to metal to provide the correct alignment.

  3. #3
    Msxslayer's Avatar
    Join Date
    May 2019
    Location
    canada
    Posts
    195
    +1
    2
    Quote Originally Posted by K447 View Post
    New impeller does not fit into the new wear ring, correct?

    Wear ring came from what source?

    Impeller is actually new, or good used, or refurbished?

    This is with the pump out of the hull, just sliding the new wear ring over the new impeller? Try that first, before trying the fit with everything pushed into the transom.

    Also make sure there is no gunk build up around the rim of the pump stator where it mates with the wear ring. The two sections must mate metal to metal to provide the correct alignment.
    Wear ring is original not new same

    Impeller brand new oem
    Same number on old blade

    Pump out of hull

    Very clean. Filing down old ring.

  4. #4
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,139
    +1
    122
    This is from an MSX140? All the pump components on MSX140 should be stainless steel. Are they? It almost sound like you an aluminum wear ring (utilized on Virage and others) that has a layer of corrosion, very common if it had been in salt water. Stainless typically stays clean.

  5. #5
    Msxslayer's Avatar
    Join Date
    May 2019
    Location
    canada
    Posts
    195
    +1
    2
    Quote Originally Posted by martincom View Post
    This is from an MSX140? All the pump components on MSX140 should be stainless steel. Are they? It almost sound like you an aluminum wear ring (utilized on Virage and others) that has a layer of corrosion, very common if it had been in salt water. Stainless typically stays clean.
    Click image for larger version. 

Name:	IMG_9143.jpg 
Views:	32 
Size:	54.9 KB 
ID:	452974

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,779
    +1
    67
    That appears to be an aluminum housing with a SS liner inside it. Polaris used those for many years.

    The problem is corrosion builds up between the liner and housing. It then expands between the layers and forces the SS liner inward. Thus making the opening smaller and not allowing the impeller to spin.

    Best option is to replace the wear ring. You can file it down, but you really want the clearance between the new impeller and wear ring to be minimal. Ideally you only want a couple thousandths of clearance between the 2 for propulsion.

  7. #7
    Msxslayer's Avatar
    Join Date
    May 2019
    Location
    canada
    Posts
    195
    +1
    2

    Wear omg question

    Quote Originally Posted by xlint89 View Post
    That appears to be an aluminum housing with a SS liner inside it. Polaris used those for many years.

    The problem is corrosion builds up between the liner and housing. It then expands between the layers and forces the SS liner inward. Thus making the opening smaller and not allowing the impeller to spin.

    Best option is to replace the wear ring. You can file it down, but you really want the clearance between the new impeller and wear ring to be minimal. Ideally you only want a couple thousandths of clearance between the 2 for propulsion.
    Ok thanks for reply. I did order a wear ring when i order a impeller. But it never came something to Do with where I live and shippin. So had to use my old one

    So I used this one , it will get me by but wonít go through this again lol
    When u get a impeller get the matching wear ring to save you time
    Last edited by Msxslayer; 08-26-2019 at 09:18 AM.

  8. #8
    Ye Ol Salty Dog's Avatar
    Join Date
    Oct 2017
    Location
    Lutz, FL
    Posts
    144
    +1
    24
    Yes, the common swelled wear ring issue. I just ripped one apart so I figured I’d upload and share some pics. If you have this issue, you’ll commonly find that a new impeller won’t fit your old wear ring because your old impeller actually got ground down a bit as the wear ring swelled and it self-clearances as it was used.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	BB7441AA-7F72-4E01-B7B0-FC622FE83402.jpg 
Views:	21 
Size:	52.2 KB 
ID:	453152  


  9. #9
    Ye Ol Salty Dog's Avatar
    Join Date
    Oct 2017
    Location
    Lutz, FL
    Posts
    144
    +1
    24
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	B6C97766-12F9-4B63-8F20-DF02235CB14B.jpg 
Views:	75 
Size:	65.2 KB 
ID:	453153  

  10. #10
    Ye Ol Salty Dog's Avatar
    Join Date
    Oct 2017
    Location
    Lutz, FL
    Posts
    144
    +1
    24
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1F5D24F1-4725-4158-A74C-ACF09E8457AE.jpg 
Views:	75 
Size:	62.4 KB 
ID:	453154  

  11. +1 by:


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wear ring question
    By Partsguy198 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 12-09-2015, 04:37 PM
  2. Wear Ring Question
    By vmanisme in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-09-2015, 07:27 AM
  3. wear ring question
    By mr. t in forum 4-Tec Performance
    Replies: 14
    Last Post: 08-30-2011, 08:45 AM
  4. wear ring question
    By canadaxp in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 04-27-2008, 01:15 PM
  5. question about wear ring
    By speedy in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 04-27-2007, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •