Results 1 to 6 of 6
  1. #1

    GP1800 running hot, worx cooling kit

    So some of you have seen my threads where I've been rebuilding a 2017 GP1800. With the help of you guys I got it fired up last week and finally got to test it today. Ran good for about 5min then warning light/temp icon appeared then limp mode. I bought this ski with tons of aftermarket parts so it's been a challenge sorting through all this. It has a worx cooling kit with billet strainer, block cooling adapter etc. I put it all back together like it appeared before I got it which is the following: rear squirt port was disconnected then a line ran to the factory intercooler, the billet strainer goes to the plastic piece above the oil cooler behind the exhaust manifold. (I'm pretty sure this isn't right as that line should go to the factory regulator but instead the regulator has a brass plug capping it off) where the factory intercooler line went now runs to the block adapter behind the intake. The rest is factory routing.

    I put a new thermostat in before starting, all pisser's are working with the port side spraying warm/hot water. The billet strainer is pouring water out when running on the hose. It should be sucking right? I'm thinking about putting it all back to stock configuration tomorrow then back to the lake to test but wanted to get opinions first.

    The line that goes to the strainer is highlighted in red. Click image for larger version. 

Name:	20190822_202831.jpg 
Views:	83 
Size:	61.6 KB 
ID:	452848


  2. #2
    Slxrider's Avatar
    Join Date
    Jul 2017
    Location
    Long Island ny
    Posts
    83
    +1
    6
    I ran the billet strainer from the pump to the intercollegiate dedicated line. The line from the inter cooler now goes to the anode on the back of the head under the intake manifold

  3. +1 by:


  4. #3
    Quote Originally Posted by Slxrider View Post
    I ran the billet strainer from the pump to the intercollegiate dedicated line. The line from the inter cooler now goes to the anode on the back of the head under the intake manifold
    Thats what I did a few min ago. From the strainer to the intercooler, old intercooler hookup now goes to the block/anode adapter. The rest I returned to stock and capped off the extra hose that hooks to where the rear vertical pisser was. The hose off the Tstat is getting warm now so I know its circulating through the head now which wasnt happening yesterday as hose never got warm. I let it idle on the hose revving every-once in awhile. Using a laser thermometer head temp never got over 147* so maybe its fixed now.

  5. #4
    Slxrider's Avatar
    Join Date
    Jul 2017
    Location
    Long Island ny
    Posts
    83
    +1
    6
    Test it in the water but should be fixed

  6. #5
    Quote Originally Posted by Slxrider View Post
    Test it in the water but should be fixed
    I put about 5hrs on it yesterday and close to 80mi in 94* temps and it never ran hot. At least no warning lights came on so I would say its fixed.

  7. #6
    Lake Lion
    Join Date
    Jul 2007
    Location
    Dirty Jerzey
    Posts
    1,273
    +1
    232
    Quote Originally Posted by Slxrider View Post
    I ran the billet strainer from the pump to the intercollegiate dedicated line.....
    That must be a very intelligent line.

  8. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 stlh 700 running hot water box extremely hot
    By Dr5734 in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-25-2018, 12:46 PM
  2. SOLD gp1800 worx ride plate
    By Boostalmighty in forum Yamaha Classifieds
    Replies: 3
    Last Post: 07-06-2018, 06:26 PM
  3. FS Worx Sponson GP1800
    By Danetwork in forum Yamaha Classifieds
    Replies: 0
    Last Post: 09-06-2017, 05:46 PM
  4. Enging Cooling Kit and Inter Cooling Kit
    By Iris in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 12-13-2012, 08:26 AM
  5. Anyone running an R&D FZR Block Thermostat Kit Cooling Option?
    By 5001craig in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 03-01-2011, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •