Results 1 to 5 of 5
  1. #1

    Join Date
    May 2019
    Location
    Jacksonville Beach, FL
    Posts
    28

    MSX150 Check Engine Light/RPM limit

    Hello all,

    Bought ski a few months ago 60hrs on it (now 72) Compression is 130 and 135 and after a pretty big headache I ended up having to replace thru hull bearing, updated oil tank, changed exhaust temp sensor, added bilge pump. Been running great since doing all that. Out of no where i started to get a check engine light after I would try to take off, the boost would climb then cut off back to around 3 or 4 bars. I Would then turn it off wait for engine light to go out and start back up. If i slowly climbed up to speed I could get full boost no problem or sometimes if I pin it hard it after a couple restarts it will finally work properly, Once i got it to full boost with out it cutting out it would run fine until I would eventually shut it down to take a break then it would do the same thing when I tried to take off again. I also feel like randomly its not taking off as quick as it used to even though it will reach full boost. Sometimes it takes off quick other times not so much. I can't remember what rpm was right now that it cuts to i think around 4200, i can check later today. I changed map sensors and that actually made it worse so I ended up putting the top one in the bottom spot and then replaced the top one with a new one and that brought it back to the original issue. (The bottom one did have some gunk on it but not bad, top one was clean) so i'm aware I might have to clean up the whole intercooler but I really hope not.

    I've been doing some research on here about checking the wastegate arm, but i'm not familiar with this and I can't seem to find some detailed instructions on where it's located and how to check to make sure its moving properly and if it's not moving freely what I can do to help with that. Also i read it could be the wastegate solenoid and I found one of those online, but I've already spent too much money on this so I do not want to buy that unless i have to. Is there a way to test that?

    Honestly I just want to fix this issue so I can sell it and get a more reliable ski This jetski is awesome when it's running right, but it seems to be out of the water more than in the water. Hard to sell something when an engine light comes on right when you take off lol.

    Appreciate any help

    THanks!
    Last edited by Yamazuki850; 08-21-2019 at 10:55 AM.

  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,881
    +1
    224
    If you still have the original boost solenoid, then that's most likely your issue. Replace it with the kit from Weberpower.com

  3. #3

    Join Date
    May 2019
    Location
    Jacksonville Beach, FL
    Posts
    28
    Quote Originally Posted by HiPeRcO View Post
    If you still have the original boost solenoid, then that's most likely your issue. Replace it with the kit from Weberpower.com
    Just found that the wastegate arm is pretty hard to move. I started doing the method of soaking a strip of an old rag with penetration oil and wrapped it around the level. I also started the ski for like 30 seconds and it got hot enough that i was able to move the lever pretty easy. How easy should it move with the actuator disconnected? Once it cooled down it got tough to move again. Ill let it soak a couple days and keep moving it. Anyone else have any other suggestions?

  4. #4
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,881
    +1
    224
    The waste gate should move very freely with nothing connected to it. Keep dousing it with penetrating oil. And the heat trick is good too, just don't overdo it.


  5. #5

    Join Date
    May 2019
    Location
    Jacksonville Beach, FL
    Posts
    28
    Thanks
    Last edited by Yamazuki850; 08-23-2019 at 11:00 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 06-27-2016, 09:24 AM
  2. Replies: 2
    Last Post: 07-14-2014, 04:36 PM
  3. 2001 Polaris Virage TXi Check engine, RPM limit 3500
    By ValBugi in forum Polaris Open Discussion
    Replies: 27
    Last Post: 06-10-2013, 09:02 PM
  4. 2002 Genesis i Check Engine Light and low RPM
    By waterhead in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 06-28-2011, 08:14 AM
  5. MSX150 6000 RPM Check Engine Light
    By MSX_150 Rider in forum MSX/Matrix
    Replies: 3
    Last Post: 09-14-2008, 02:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •