Results 1 to 5 of 5
  1. #1

    Polaris 650 coupler and driveshaft Stripped

    I bought this 650 a couple weeks ago and after new carb kits it ran like a champ. Last time out, pulled up to a sand bar, shut off and coasted to it. Got ready to leave pushed off before cranking, cranked and no propulsion, just revving. Tore down and splines on shaft are different heights. Some sharp, some flattened. I know I need new shaft. I canít find this type of coupler or pto coupler online anywhere. I am assuming it is also stripped since shaft that goes into it looks stripped or not perfect at the very least. Anyone know where to find this?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	4A3785AF-3B92-4069-829D-45FC20960149.jpg 
Views:	15 
Size:	72.9 KB 
ID:	452711   Click image for larger version. 

Name:	FF16AEEC-D462-477B-8DB5-3EBD2C83E185.jpg 
Views:	12 
Size:	66.7 KB 
ID:	452712  


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,634
    +1
    54
    It's a good chance you sucked up a rock or something causing the pump to not spin and causing the threads to wipe out.

    Those couplers are all over Ebay if no one on here has one for sale.

    The drive shaft should be available on there as well.

  3. #3
    I found the drive shaft but all the couplers look different than this one. Found one site that showed on search but when I went there they didn’t have them.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,634
    +1
    54
    Wow, where did all the solid couplers go?

    Only found this one doing quick search. https://www.ebay.com/itm/1995-Polari...oAAOSwXlpcfagj

    The good news is, you can install the larger rubber cushioned coupler with no problem. You'd need to buy the plastic cover for it also, but you can do the swap if need be.

  5. #5

    Join Date
    Aug 2007
    Location
    Wisconsin
    Posts
    175
    +1
    2
    Check to make sure the engine is not moving at all. I had one of my pro 785s come loose from the engine plate and the engine moving up and down was enough to strip drive shaft splines left and right. Give that engine Good tug and make sure it's not moving at all.

    Might want to check alignment too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stripped PTO Coupler
    By mjet in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-26-2019, 08:11 PM
  2. WTB - Parts Looking for 5130844, driveshaft coupler for 1994 Polaris SLT 750
    By littered in forum Polaris Classifieds
    Replies: 0
    Last Post: 09-18-2018, 11:58 PM
  3. Polaris SL 700 driveshaft coupler. small model big model
    By shogangp in forum Polaris Tech Tips and Info
    Replies: 1
    Last Post: 07-19-2014, 08:31 PM
  4. RPM coupler setscrew heads are stripped and I need to get this cylinder off ASAP HELP
    By ProXR 440 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-29-2009, 01:20 PM
  5. GPR coupler stripped off!!
    By team11haro in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 04-15-2007, 09:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •