Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25
  1. #21
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,052
    +1
    1,867
    Quote Originally Posted by ncdoo View Post
    How do you screw a worm clamp on "backwards"?
    Use a left handed nut driver! LOL

  2. #22
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,052
    +1
    1,867
    Quote Originally Posted by 05_RXP View Post
    I have never had any kind of luck with worn gear clamps on anything boost related
    No matter which type of clamp is used cleaning both mounting surfaces is needed. Use alcohol to remove oil residue or other contaminates from outside/inside piping/hoses.
    i use AWAB clamps from the turbo, IC, to TB at 22 psi boost!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	C18FC8CF-4661-4E50-B3ED-36211B76ADFE.jpg 
Views:	46 
Size:	78.7 KB 
ID:	454900  

  3. #23
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,752
    +1
    908
    I have black and some blue sets in stock. I also have black sets to go with a blow off valve. I'm here if you guys have any questions. Thanks guys!

  4. #24
    LPG256's Avatar
    Join Date
    May 2009
    Location
    NOBLESVILLE, IN
    Posts
    111
    +1
    12
    This one came in to me today.
    Bone stock 300.
    Ran ~ 2 hrs after another dealer did the s.c. wheel recall.
    Bad install on the hose. Twisted it enough to "kink" it on the bottom / back side.
    Restricted air flow.

    Just throwin' it out there to remind everyone to be careful installing no matter what brand you use.

    I like fizzle's Click image for larger version. 

Name:	20191017_133402.jpg 
Views:	38 
Size:	82.6 KB 
ID:	455102Click image for larger version. 

Name:	20191017_133515.jpeg 
Views:	34 
Size:	127.7 KB 
ID:	455103

  5. #25
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,392
    +1
    924
    I opted for the Riva and really like them.
    After having T-Bolt clamps pop off, especially at the charger side of SeaDoo since it is a smaller clamping surface, I personally like GOOD worm clamps like ABA or ADA much better than T-Bolt clamps.
    The key is to use something like lacquer thinner to clean the inside of the pipes and the pipe it is attaching to good, then spray it with window cleaner (foam kind works well). It seems to act like an adhesive.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20190914_201218.jpg 
Views:	28 
Size:	85.9 KB 
ID:	455105  


Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS Riva Intercooler Pipes 300
    By Yanksfan in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 07-04-2018, 08:56 AM
  2. WTB 300 riva intercooler pipes ...needed
    By IM2FAST4U in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 08-06-2017, 03:01 PM
  3. 300 IC Hard pipes
    By Water4fire in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-30-2016, 07:05 PM
  4. Hard intercooler pipes for Seadoo 300?
    By Titan_Joe in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-14-2016, 06:08 AM
  5. FS 28 hour SVHO Intercooler & charge pipes
    By Chupacobra in forum Yamaha Classifieds
    Replies: 10
    Last Post: 08-11-2016, 12:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •