I'm new to this forum, hope you can help.
I have 2 seadoo spark 2015: 2 up and 3up.
When I got them I purchased the Candoo pro and did the "dealer" maintenance replacing the oil, oil filter three spark plugs. Cleared up the computer and got them in the water. I have been using them for a while without any issues, until 2 weekends ago that the 3up shutdown almost at the marina and would not start. I pulled it to the trailer with the 2up and returned home.
Since then initially I though it was the relay and replaced it, checked the fuses, check the battery (the connectors), but all I get is a clicking noise. Then I decided to pull the starter just in cases there was an issue but it rotates without any issue. Reading thru different forums I though that the engine was siezed. I remove all 3 spark plugs and tried once again and it just does not turn. I tried to turn it thru the impeller but it is too hard.
Since I cannot start the engine there is little that I can see with the candoo pro.
I'm out of ideas, let me know if you have any suggestions.