Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    94 slt 750 no mid range power

    I took out my 750 for the first time it keeps bogging down at about half throttle and doesnít feel like itís going too speed. If I choke it at mid throttle it will pick up and go. It was sitting for a minimum of 15 years. Probably some stupid like carb cleaning but just need advice on it donít know too much about these machines


  2. #2

    Join Date
    Aug 2007
    Location
    Wisconsin
    Posts
    147
    +1
    2
    If you ever add choke and it runs better it's too lean. That carb is probably filthy and not delivering enough fuel.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,614
    +1
    54
    Agreed ^^^^^^

  4. #4
    Plugs are coming up straight soaked black as of right now

  5. #5

    This is how it runs

  6. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    5,058
    +1
    145
    Video is out of the water and doesn't say much..... If on the water, as xlint amd sldvx said you are running lean....

  7. #7
    Carbs are clean still going to put new diaphragm in them but pop off springs are going off at 16 psi also would reed spacers and possibly dual stage reed be worth putting in while it’s apart

  8. #8
    Still haven’t figured out the bogging issue rebuilt the carbs correct fuel pressures all new intake gasketsstill keeps bogging. Down at mid range. Any ideas only way it runs half decent is when the exhaust backfires and shoots the pipe from the water box to the hull pass through off of it

  9. #9
    ThrottleOut's Avatar
    Join Date
    Aug 2011
    Location
    Corning, NY
    Posts
    774
    +1
    33
    I would highly recommend going through the carbs very thoroughly and upgrading to the triple outlet fuel pump. The single outlet pumps were barely enough when new, add some wear and tear and you are asking for trouble. Do a search on here for triple outlet pump and you'll get a lot of results. The fuel system is the weak link on these Fuji engines, get that nailed down and you should have a good reliable machine. Without doing the recommended updates you risk burning a hole in a piston from a lean burn-down.

  10. #10

    Join Date
    Sep 2015
    Location
    Nova Scotia, Canada
    Posts
    295
    +1
    16
    If it sat a long time and runs good without the exhaust hooked up is it possible some rodent built a nest in the exhaust?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 SPX - 657 no mid range power
    By JoeHolland2013 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-15-2017, 11:59 AM
  2. Zxi 750 mid range bog
    By CaptaimBosco in forum Kawasaki Projects
    Replies: 2
    Last Post: 07-13-2016, 10:55 PM
  3. no mid range power help!
    By Corey_ in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-28-2012, 04:48 PM
  4. Replies: 45
    Last Post: 04-07-2010, 10:53 PM
  5. 1200 xl missing mid range power???
    By baumer33 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-25-2008, 09:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •