Results 1 to 8 of 8
  1. #1
    AlexFZR's Avatar
    Join Date
    Aug 2018
    Location
    Rome - Italy
    Posts
    101
    +1
    3

    Fzr sho 2009 - Jet pump problem, noise & vibration

    2 days ago I came out with a rough sea, when I was coming back, after about 2h I heard a noise coming from behind. When I give gas I feel that I don't have the maximum propulsion, at the same time the more RPMs increase, the more I feel tremble behind. When they are at a speed of 30/40 MPH the bike goes on its own. At maximum speed I do not reach more than 50 MPH. I believe there is a problem with the hydro-jet, I will try to send a photo of the imppeller (certainly to change).
    I hope someone can help me understand what the problem is in order to save on spare parts, instead of changing them all

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20190815_203928.jpg 
Views:	203 
Size:	57.1 KB 
ID:	452632  
    Last edited by K447; 08-19-2019 at 08:37 AM. Reason: Title clarity


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,177
    +1
    1,984
    What model and year?

    How many running hours?

    Has the jet pump ever been serviced or rebuilt?

  3. +1 by:


  4. #3
    AlexFZR's Avatar
    Join Date
    Aug 2018
    Location
    Rome - Italy
    Posts
    101
    +1
    3
    Quote Originally Posted by K447 View Post
    What model and year?

    How many running hours?

    Has the jet pump ever been serviced or rebuilt?
    Fzr sho 09, 160h, jet pump never serviced and never rebuilt.

  5. #4
    SOV's Avatar
    Join Date
    Nov 2014
    Location
    Cluj-Napoca, Romania
    Posts
    190
    +1
    7
    Hi,

    I have same ski same year...just dismount the pump then you will see the problems.
    Prop is dameged and as I can see, the tunnel too. Check the ring also, it is very important.

    Sergiu

  6. +1 by:


  7. #5

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,417
    +1
    101
    Pull the pump a few bolts and pipes and cables and the whole lot driveshaft back will slide out. Once out take the cone off the rear 3 Allen head bolts chances are bearings are shot and need replacing
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	213D41ED-F93F-4E63-8484-F26C2DC5F92B.png 
Views:	13 
Size:	378.0 KB 
ID:	452676   Click image for larger version. 

Name:	737D87CD-168A-42F2-B303-69DC1F9D2964.png 
Views:	12 
Size:	419.6 KB 
ID:	452675  

  8. +1 by:


  9. #6
    yup the pump needs rebuilding

  10. #7
    AlexFZR's Avatar
    Join Date
    Aug 2018
    Location
    Rome - Italy
    Posts
    101
    +1
    3
    Quote Originally Posted by SOV View Post
    Hi,

    I have same ski same year...just dismount the pump then you will see the problems.
    Prop is dameged and as I can see, the tunnel too. Check the ring also, it is very important.

    Sergiu
    Thanks man. I keep it in my mind.

  11. #8
    AlexFZR's Avatar
    Join Date
    Aug 2018
    Location
    Rome - Italy
    Posts
    101
    +1
    3
    Quote Originally Posted by HDAV View Post
    Pull the pump a few bolts and pipes and cables and the whole lot driveshaft back will slide out. Once out take the cone off the rear 3 Allen head bolts chances are bearings are shot and need replacing
    Thanks man, i will update you.

  12. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris jet unit
    By nz fulla in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 08-27-2015, 08:51 PM
  2. jet pump unit and shaft
    By xhawkxx in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 02-08-2013, 04:37 PM
  3. Fuel sending unit problem?
    By Tedcfitz in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-23-2012, 07:24 PM
  4. RXP-X 'Inversion' Jet Unit
    By Brad Clarke in forum 4-Tec Performance
    Replies: 80
    Last Post: 03-13-2008, 10:02 PM
  5. torque for jet unit bolts???
    By RDH in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 07-14-2007, 02:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •