Results 1 to 5 of 5
  1. #1

    2002 Virage intermittent electrical

    Hello,
    Thanks in advance.
    I picked up a 02 virage 700 that starts and runs great except an intermittent electrical glitch.
    First, noticed that the display will go to "sleep" while riding and the machine goes into what seems like a limp mode. We discovered that pushing any display button " wakes " it up and it will then be fine. Has done this multiple times with no consistency.
    Second, noticed that at times it will run great but no RPM readings on display.
    Third thing it did, one time when docking I hit the stop switch and it turned off but immediately restarted and kept cranking even after I pulled the lanyard. At that time, the display was flashing low fuel warning. A hit to the left handlebar near the switch stopped it and then it was fine like nothing happened.
    So what I initially thought was I should replace the handle bar switches but after researching here I was wondering about the LR505 rectifier. Could a bad rectifier cause all those symptoms. Ive ran through all the connections and grounds I can find and nothing seems off. Can anyone give me a run down on how to trouble shoot the switch or rectifier or other cause?
    thanks again.


  2. #2

    Join Date
    Aug 2007
    Location
    Wisconsin
    Posts
    175
    +1
    2
    The display gets the signal to wake up from the tachometer and the RPM reading. You are not getting a steady RPM reading from the electrical box to the MFD, probably a damaged wire somewhere.

  3. #3
    I don't think it's just a bad wire. If you mean the yellow wire, I've traced it through the electrical box to the display and there is no issue there. All clean tight connections as far as I can tell.
    It's the multiple symptoms that made me think regulator/rectifier.
    Should add that the battery is 12.4 across terminals and drop to 12 while cranking. The display has never shown voltage above 11.

  4. #4
    Follow up for those reading this.
    I replaced the voltage regulator. Went to ebay and searched lr505 polaris. After market part for about $35 shipped to door.
    Just got done riding for four days at the cabin and it seems that replacing the regulator has corrected the issue, worked perfect the whole time. Can't say how the part will hold up over time ,but the machine is working now.

  5. #5
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,969
    +1
    1,947
    Quote Originally Posted by dannypz View Post
    ...
    I picked up a 2002 virage 700 that starts and runs great except an intermittent electrical glitch.
    First, noticed that the display will go to "sleep" while riding and the machine goes into what seems like a limp mode. ...

    Second, noticed that at times it will run great but no RPM readings on display.

    Third thing it did, one time when docking I hit the stop switch and it turned off but immediately restarted and kept cranking even after I pulled the lanyard. At that time, the display was flashing low fuel warning. A hit to the left handlebar near the switch stopped it and then it was fine like nothing happened.

    ... Could a bad rectifier cause all those symptoms? ...
    Replacing the LR-505 with an aftermarket part correct ALL the issues listed above?

    I will mention that if the original start solenoid is still installed it should be replaced. The factory original solenoids tend to fail and a common failure mode is for the engine to crank continuously even without pressing the start button. This can happen without warning and sometimes will crank until the battery post literally melts or the starter motor burns out.

    While out on the water you do not want to risk this sort of failure. The newer solenoids are a better design.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 injected virage intermittent bogging and gas smell
    By 48Straight in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-10-2016, 12:43 PM
  2. FS - Parts 2002 Virage full wiring harness w/ electrical box, 96 780 Electrical box, Mirrors, FA
    By UnityRacing in forum Polaris Classifieds
    Replies: 1
    Last Post: 07-11-2014, 09:09 AM
  3. water in electrical box on 2002 Polaris Virage TX
    By schnookie in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 05-31-2013, 06:28 PM
  4. 2002 Virage TXi intermittent stalling
    By dsmedley in forum Polaris Open Discussion
    Replies: 31
    Last Post: 05-05-2011, 05:34 AM
  5. 2002 Polaris Virage I Electrical Problem
    By gusie1 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 09-30-2007, 07:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •