Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 39
  1. #21
    Link to the video:


    Let me know if there's anything I've missed.

  2. #22
    If itís back firing I think itís a timing issue. I also remember someone having an issue where it turned out to be the timing rotor on the crankshaft. There were two different types for the same ski or something of that sort, they looked very similar but for a few extra teeth. The problem went away when the guy swopped out the timing rotor with the correct one.

  3. #23

    Join Date
    Aug 2015
    Location
    Ct.
    Posts
    445
    +1
    43
    Quote Originally Posted by rotaryboots View Post
    Link to the video:


    Let me know if there's anything I've missed.
    I don't rev my machine out of the water like that. I do know after I flush it I blip the throttle pretty good to minimize water in the water box, but I don't hold the throttle there. I think mine would hit a "rev limiter" like yours does on dry land. Kind of hard to decipher if it is popping through the throttle body in that vid or backfiring out the exhaust or just hitting a normal rev limiter out of the water without a load.

  4. #24
    Completely agree on revving out of water. Made sure to keep it quick so it wouldn't heat up.

    Hits that 4k rpm limiter as shown in the video. It's the same on the hose or on the water.

    If I give it more than half throttle, that is when it will really bounce the rpms and pop back through the intake.

    Perhaps I can mark one of the teeth with a paint pen through the sensor hole and then rotate the engine over and count them. IIRC a 15F should have 8 teeth.

  5. #25

    Join Date
    Aug 2015
    Location
    Ct.
    Posts
    445
    +1
    43
    I just noticed this is in the FAQ and How To section. Think it should be moved to the Kawi 4 stroke section. It might get more input.

  6. #26
    That's where I had it originally, then it got moved here

  7. #27

    Join Date
    Aug 2015
    Location
    Ct.
    Posts
    445
    +1
    43
    Quote Originally Posted by rotaryboots View Post
    That's where I had it originally, then it got moved here
    Makes no sense. This is you asking for help, not a how too.


  8. #28
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,222
    +1
    710
    Quote Originally Posted by rotaryboots View Post
    How is that stroke measured? From piston head to?
    Ummm... Yes!

  9. #29
    Quote Originally Posted by TJS0712F View Post
    Makes no sense. This is you asking for help, not a how too.
    I know. I didn't move it. Hopefully a mod see's this and moves it back

  10. #30
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,886
    +1
    365
    Quote Originally Posted by TJS0712F View Post
    Makes no sense. This is you asking for help, not a how too.
    If you read the section headings, the "performance" section is for discussing upgrades and performance modifications, the "how to and faq" is for asking questions, the "projects" section is for build logs, and the "tech tips and info" section is for posting guides.

    I requested the how to section name be changed to problem solving and the other mods are discussing it.

    This is the correct section for the post which is why it was moved.

    Sean

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vx deluxe won't rev above 5000 rpm's
    By dixiesal in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 08-10-2019, 05:04 PM
  2. 2011 stx15f won't rev past 4,000 rpm
    By ftp11 in forum Kawasaki How To & FAQs
    Replies: 6
    Last Post: 07-29-2016, 09:58 AM
  3. 1999 GP800 bogs down between 3000-4500 RPM, but runs great after 4500 RPM
    By Michaelbarth in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-20-2011, 06:42 AM
  4. 2000 GP800R Won't Rev above 3-4K RPM
    By Raider3 in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 08-08-2010, 10:56 AM
  5. 96 SL 780 won't rev above 2500 rpm
    By twinSL780s in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-05-2009, 10:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •