Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11
    Sweet, awesome to hear!

  2. #12

    Join Date
    Jul 2016
    Location
    Lake Wynonah, Pennsylvania
    Posts
    35
    Quote Originally Posted by Mrscudder View Post
    Sweet, awesome to hear!
    it runs but has a gray kinda smoke to it. got a fuel leak as well. new starter relay is coming tomorrow night. im trying to find the "display bypass" to see if it works. i don't remember what i did yesterday when testing but i heard the chime and screen lit up for about 2 seconds.


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power on yamaha suv gp1200.
    By birdgod in forum Yamaha PWC Performance (2-stroke)
    Replies: 45
    Last Post: 08-15-2015, 03:22 AM
  2. gp1200 gauge cluster temporary power
    By irelandd in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 01-04-2015, 10:30 PM
  3. 00 gp1200 no power!!!!!help
    By Mvpxspeedy in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 09-08-2011, 01:04 PM
  4. GP1200 no power - electrical
    By howie099 in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 08-16-2010, 07:03 AM
  5. 2000 GP1200 Power Issue
    By deadbeat in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 08-18-2008, 07:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •