Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32
  1. #1
    zperez2012's Avatar
    Join Date
    Aug 2019
    Location
    Savannah , Ga
    Posts
    12

    New to me Ultra 150s , need to get them back on the water

    So long story short I picked up a couple jetskis this weekend for free. guy said they all ran when parked . Got home , they have all been drained of gas and disconnected (good sign) . One is built the other is stock . Got the modified one to turn over and it shot blue mix oil out of the cylinders for a little while , put the plugs back in and poured a little mix gas and it turned over and sparked up for a second (good sign) . After that it just started clicking like the battery was dead? Now it wonít turn over ? Any advice or tips for that? The other one just clicks and doesnít turn over , thinking solenoid or starter for either ski . Theyíre both clean and motors are spotless . New to them but Iím pretty handy thanks in advance
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	5A4BE688-E6A9-4FD3-92BC-BCDC62770D17.jpg 
Views:	37 
Size:	248.4 KB 
ID:	451891   Click image for larger version. 

Name:	9A1ABC8D-3368-4B28-A6A7-CED0604EE604.jpg 
Views:	34 
Size:	211.3 KB 
ID:	451892   Click image for larger version. 

Name:	4365F8CD-4F0D-4489-86D5-7579EF9CB8B5.jpg 
Views:	34 
Size:	208.0 KB 
ID:	451893  


  2. #2
    Quote Originally Posted by zperez2012 View Post
    So long story short I picked up a couple jetskis this weekend for free. guy said they all ran when parked . Got home , they have all been drained of gas and disconnected (good sign) . One is built the other is stock . Got the modified one to turn over and it shot blue mix oil out of the cylinders for a little while , put the plugs back in and poured a little mix gas and it turned over and sparked up for a second (good sign) . After that it just started clicking like the battery was dead? Now it wonít turn over ? Any advice or tips for that? The other one just clicks and doesnít turn over , thinking solenoid or starter for either ski . Theyíre both clean and motors are spotless . New to them but Iím pretty handy thanks in advance
    I would start with pulling the plugs which it sounds like you did. Then crank it over until all the oil is out of the cylinders. If they won't crank over with the plugs removed then make sure the battery is good of course. Then I would recommend pulling the pump to verify that it isn't locked up. If the pump is locked up the motor won't be able to turn. The motor is directly connected to the pump. There is no clutch or transmission. If the motor is turning the pump is turning. If the pump is seized the motor won't be able to turn. Granted it is unlikely the pump is frozen solid if they ran fine when they were put away but they could have corroded and are now locked up. Of course it could be the starter, a blown rod, stuck rings, etc.

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,905
    +1
    668
    Welcome aboard, zperez2012!

    If you remove the jet pump, do NOT start the engine! Just see if you can turn it over by hand with the spark plugs removed.

  4. #4
    I just want to say I am jealous of that trailer.

  5. #5
    Quote Originally Posted by steve45 View Post
    Welcome aboard, zperez2012!

    If you remove the jet pump, do NOT start the engine! Just see if you can turn it over by hand with the spark plugs removed.
    You can't start the engine with the jet pump removed? I didn't know that. I believe I have started mine without the pump installed but I could be mistaking.

  6. #6
    Yes you can start engine with jetpump removed. Just make sure you pull drive shaft back so its not hitting the coupler

  7. #7
    Quote Originally Posted by turboman412 View Post
    Yes you can start engine with jetpump removed. Just make sure you pull drive shaft back so its not hitting the coupler
    Exactly. I slid the driver shaft out of the coupler so it wasn't engaged when I ran the motor with the pump removed. I thought that was safe.

  8. #8
    zperez2012's Avatar
    Join Date
    Aug 2019
    Location
    Savannah , Ga
    Posts
    12
    Quote Originally Posted by beekermartin View Post
    I would start with pulling the plugs which it sounds like you did. Then crank it over until all the oil is out of the cylinders. If they won't crank over with the plugs removed then make sure the battery is good of course. Then I would recommend pulling the pump to verify that it isn't locked up. If the pump is locked up the motor won't be able to turn. The motor is directly connected to the pump. There is no clutch or transmission. If the motor is turning the pump is turning. If the pump is seized the motor won't be able to turn. Granted it is unlikely the pump is frozen solid if they ran fine when they were put away but they could have corroded and are now locked up. Of course it could be the starter, a blown rod, stuck rings, etc.
    Okay Iím gunna pull them again and try . The clicking makes me think a solenoid so Iím bout to put a hot battery in it and try again. If anything Iíll try to jump the solenoid as well. Forgot to mention that itís got a billet head , carbon fiber air filter pods , I think upgraded carbs and a full exhaust and not sure what else .

  9. #9
    zperez2012's Avatar
    Join Date
    Aug 2019
    Location
    Savannah , Ga
    Posts
    12
    Thanks! I didn’t have a clue they made 4 ski trailers? Kinda resembles a pontoon but hey the whole setup was free so I’m just gunna ride with it

  10. #10
    Quote Originally Posted by zperez2012 View Post
    Okay I’m gunna pull them again and try . The clicking makes me think a solenoid so I’m bout to put a hot battery in it and try again. If anything I’ll try to jump the solenoid as well. Forgot to mention that it’s got a billet head , carbon fiber air filter pods , I think upgraded carbs and a full exhaust and not sure what else .
    Post some pics when you get a chance. I imagine some people here will know what most of the mods are.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 3 ultra 150s (all best handling mods)
    By skoolball23 in forum Kawasaki Skis
    Replies: 3
    Last Post: 10-17-2017, 05:50 AM
  2. 2 ultra 150s and double trailer for sale
    By JDB636 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-16-2016, 12:59 PM
  3. How long do ultra 150s last?
    By Ultra150top in forum Kawasaki PWC Performance (2-stroke)
    Replies: 9
    Last Post: 06-01-2012, 08:42 AM
  4. FS Parting out 2 ultra 150s
    By ALOHR in forum Kawasaki Classifieds
    Replies: 8
    Last Post: 01-25-2012, 05:08 PM
  5. peteshauling kicking ultra 150s ass
    By dv8raaz in forum Videos & Pictures
    Replies: 5
    Last Post: 10-27-2005, 10:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •