Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Jul 2019
    Location
    utah
    Posts
    24

    In need of assistance...

    iím gonna start off by saying thank you to all of those that have helped me on this forum. you have helped my get an old neglected machine up and running. i just need a little more help from yíall to get her runnin great. so on my 1994 SLT 750 i cleaned the carburetors, upgraded to triple outlet fuel pump, and replaced the old cracked brittle fuel lines inside the gas tank. at this point the jet ski starts right up idles very smooth and well, my issue is that it bogs down when transitioning from low speed to high speed, and when accelerating too fast, if you accelerate at a slow pace itís fine. once you get into the high speed it blasts and is fine, however after a while at WOT the rpms drop and it doesnít run as strong at full throttle. i know that all of this is likely because of it running lean, however i am lost at this point because iíve already replaced most of the fuel system and adjusted the highs and lows all over the place. the condition seems to improve when i back out the low speed screws, however they are already out almost a full two turns, compared to the factory 1/2 turn. leading me to believe it is getting too much air, just not sure where from. any help is much appreciated. please put any responses into terms a 16 year old would understand, as i am actually only 16 🤣

  2. #2
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,917
    +1
    30
    Quote Originally Posted by 1994slt750 View Post
    i’m gonna start off by saying thank you to all of those that have helped me on this forum. you have helped my get an old neglected machine up and running. i just need a little more help from y’all to get her runnin great. so on my 1994 SLT 750 i cleaned the carburetors, upgraded to triple outlet fuel pump, and replaced the old cracked brittle fuel lines inside the gas tank. at this point the jet ski starts right up idles very smooth and well, my issue is that it bogs down when transitioning from low speed to high speed, and when accelerating too fast, if you accelerate at a slow pace it’s fine. once you get into the high speed it blasts and is fine, however after a while at WOT the rpms drop and it doesn’t run as strong at full throttle. i know that all of this is likely because of it running lean, however i am lost at this point because i’ve already replaced most of the fuel system and adjusted the highs and lows all over the place. the condition seems to improve when i back out the low speed screws, however they are already out almost a full two turns, compared to the factory 1/2 turn. leading me to believe it is getting too much air, just not sure where from. any help is much appreciated. please put any responses into terms a 16 year old would understand, as i am actually only 16 藍
    Why did you change the low and high speed settings?

  3. #3
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    5,061
    +1
    146
    Lots to do, starting with Rebuild the carbs. Then tune them... It will cost $$$$

  4. #4

    Join Date
    Jul 2019
    Location
    utah
    Posts
    24
    i adjusted them as necessary after i rebuilt the carbs.

  5. #5

    Join Date
    Jul 2019
    Location
    utah
    Posts
    24
    again?? i just did a week ago

  6. #6

    Join Date
    Jul 2019
    Location
    utah
    Posts
    24
    Quote Originally Posted by BlueFishCrisis View Post
    Lots to do, starting with Rebuild the carbs. Then tune them... It will cost $$$$
    again?? i just did about. a week ago

  7. #7

    Join Date
    Jul 2019
    Location
    utah
    Posts
    24
    Quote Originally Posted by Drkvampire2001 View Post
    Why did you change the low and high speed settings?
    i adjusted them as necessary after i rebuilt the carbs

  8. #8
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,917
    +1
    30
    Quote Originally Posted by 1994slt750 View Post
    i adjusted them as necessary after i rebuilt the carbs
    there is no reason to adust them after rebuilding the carbs, start by putting them back to stock settings.

  9. #9

    Join Date
    Jul 2019
    Location
    utah
    Posts
    24
    Quote Originally Posted by Drkvampire2001 View Post
    there is no reason to adust them after rebuilding the carbs, start by putting them back to stock settings.
    it still seems like it’s running lean when at stock settings and doesn’t idle very well. any ideas on the reason for this?

  10. #10
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,917
    +1
    30
    Quote Originally Posted by 1994slt750 View Post
    it still seems like it’s running lean when at stock settings and doesn’t idle very well. any ideas on the reason for this?
    You can adjust the idle speed at the cable on the carb, there should be an adjustment there, RPM should be roughly 3K on land, or 1,500 +/- 100


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need assistance!!!
    By Kawasaki10 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 07-28-2013, 12:18 PM
  2. Need assistance with performance
    By louch in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 04-01-2009, 08:11 AM
  3. PH20CRAFT.. need some assistance ;)
    By brad148405 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 01-09-2009, 11:23 AM
  4. I Might need some assistance @ MB
    By ou812 in forum Mudbug Nationals PWC.Life Rally
    Replies: 19
    Last Post: 06-09-2008, 08:41 PM
  5. Roadside Assistance
    By Pale Rider in forum Open Discussion
    Replies: 12
    Last Post: 12-26-2007, 10:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •