Results 1 to 5 of 5

Thread: 2019 310r

  1. #1

    Thumbs down 2019 310r

    Had anyone installed a wideband on a 300-310? If so where did you place the wideband.. Iv attempt to installed on on my 310r. And it seems like there water in the exh. I installed the sensor in a dry port “The small Allen head” but it’s still getting water to the sensor and Should water be that far up the exhaust? Or did I nick a water jacket when driving and tapping?


  2. #2
    This seems alittle more then a splash. I’m getting a soaking wet sensor.. I had no idea there was that much water that far up stream.. what’s the chances Iv tapped into a water jacket?. Iv got it pretty centered..
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	9A72CC78-9BDB-4B3F-9473-42E27B59B1E7.jpg 
Views:	24 
Size:	52.2 KB 
ID:	451549  

  3. #3
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,477
    +1
    678
    Quote Originally Posted by MWHC View Post
    you can put it there but you cannot idle with it there. once the box fills up with water it will splash the sensor 100% of the time. there's a few other options but no great ones
    Mick is 100% correct......… I have destroyed over the years atleast 12+ sensors .....

  4. #4
    Quote Originally Posted by sirbreaksalot View Post
    Mick is 100% correct......… I have destroyed over the years atleast 12+ sensors .....

    With that much water at the top of exhaust is it ok to run the race plate exhaust filter delete? I’ll get some video today and see what you guys think. I have the exh elbow off at the moment... had anyone had issues getting the sensor to seal? Mine has alittle bit of water coming from around the treads.. there’s only like 3treads on a o2 sensor holding it on there

  5. #5
    With that much water at the top of exhaust is it ok to run the race plate exhaust filter delete? I’ll get some video today and see what you guys think. I have the exh elbow off at the moment... had anyone had issues getting the sensor to seal? Mine has alittle bit of water coming from around the treads.. there’s only like 3treads on a o2 sensor holding it on there

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2019 Yamaha VX Limited, 2019 VX Cruiser HO, same top speed? First post...new owner
    By JRod28 in forum Yamaha PWC Performance (4-stroke)
    Replies: 26
    Last Post: 08-08-2019, 12:36 AM
  2. GTi pro 2019 or GTX 155 2019
    By morro23pr in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-04-2019, 11:11 AM
  3. 2019 yamaha fx svho cruiser vs 2019 sea doo rxt x
    By Nb707 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-08-2019, 02:35 PM
  4. 2019 Seadoo RXT 230 vs 2019 Yamaha FX SVHO ?
    By arctic388 in forum Open Discussion
    Replies: 1
    Last Post: 05-07-2019, 12:57 AM
  5. 2019 Mark Hahn Memorial 300 February 23, 2019
    By Socaloffshore in forum Race Events and News
    Replies: 5
    Last Post: 02-27-2019, 06:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •