Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Sorry, meant the bottom/electrode side of the plug, kind of like rings goings bad or excessive crank case pressure. The top of the plug was completely dry and I replaced those seals when I did valve springs and retainers not too long ago.

  2. #12
    Those metal particles are normal, if they are steel. Take a magnet and check.

    People seem to forget that the starter ring gear and bendix are bathed in oil. The edges of both get chipped off and end in the oil filter.


  3. #13
    I change the oil and filter every year regardless of hours( i never do anywhere near 25 per year).

  4. #14
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,258
    +1
    44
    I have a 2016 RXPS, 35 hrs and have metal flecks. Not as many as you but they are there. I was told it was normal last time I was talking with a seadoo tech.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 Seadoo rxp excessive metal in oil filter
    By Amwhit8611 in forum 4-Tec Performance
    Replies: 73
    Last Post: 03-02-2018, 10:52 AM
  2. Scotts Performance Metal oil filter with 304 Stainless Steel micro filter cloth
    By Saum700p in forum Yamaha PWC Performance (4-stroke)
    Replies: 30
    Last Post: 11-27-2017, 08:30 AM
  3. 04 RXP Metal in Oil Filter
    By jsnacker in forum 4-Tec Performance
    Replies: 24
    Last Post: 08-16-2015, 09:09 PM
  4. Metal In oil filter!! What to do now...
    By ctdarnell in forum Sea Doo Open Discussion
    Replies: 24
    Last Post: 07-31-2012, 11:46 PM
  5. 06 RXP metal shaving in oil filter
    By rxp127 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-05-2011, 02:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •