Results 1 to 9 of 9
  1. #1

    Seadoo 717 need help

    new to the forum and help would be very appreciated I have a 95 seadoo Xp with the 717 motor I just done a top and bottom rebuild on it I used WSM Platinum pistons on it I had the cylinders Bored to 82.5mm at my local Machine shop and put the motor all back together and Installed it back in the hull I did the timing right off the manual 147 degrees And closing at 65 degrees and everything when I try to start it I have to pump the throttle To get it to crank it fires up for less then a minute then dies and I try to start it back and all it does is start for a Second then blow smoke out of both Carburetors when I take the spark plugs Out they are wet

  2. #2
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,357
    +1
    131
    Did you clean/rebuild carbs ??? Does it have grey fuel lines ???

  3. #3
    Carbs have been rebuilt no grey lines I replaced them when I try to spray gas into the carb intake it blows the gas back out and when you pull the plugs and put some gas into the cylinders it fires up for a second and then fire shoots out the intake thanks


  4. #4
    Is the rv valve spinning?

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,666
    +1
    259
    Quote Originally Posted by Wire4Money View Post
    Is the rv valve spinning?
    Also, did you place the rv with front piston at tdc?

  6. +1 by:


  7. #6

    Join Date
    Sep 2014
    Location
    Southern middle TN
    Posts
    435
    +1
    153
    sounds like the rotary valve is not set right. it may need to be flipped over. did you use the marks on the case or a timing wheel?

  8. #7
    Quote Originally Posted by Wire4Money View Post
    Is the rv valve spinning?
    Yes it is

  9. #8
    Quote Originally Posted by Myself View Post
    Also, did you place the rv with front piston at tdc?
    Yes I did the timing at tdc on front piston

  10. #9
    Quote Originally Posted by arctic388 View Post
    sounds like the rotary valve is not set right. it may need to be flipped over. did you use the marks on the case or a timing wheel?
    Timing wheel 147 degrees and closing at 65 degrees

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts Parting Out 95 SeaDoo XP 717
    By ndj22 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 03-21-2017, 06:51 PM
  2. '95 Seadoo XP 717 restoration!
    By SheldonZ28 in forum Sea Doo Build Threads
    Replies: 1
    Last Post: 10-03-2016, 05:13 PM
  3. Seadoo 717 BOGGING?!?!
    By Kaleb SL750 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-18-2012, 02:21 AM
  4. seadoo 717 question
    By gtx-x2 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-31-2010, 10:14 PM
  5. Seadoo 717 engine
    By mightyjoe894 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 04-08-2008, 08:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •