Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    May 2012
    Location
    California
    Posts
    1,928
    +1
    181

    looking for 2002 gtx 4tec computer

    part 664130 or even a 664133, I have the emulator so I can take that out or leave it in. N/A 155 GTX 2002.

  2. #2

    Join Date
    May 2012
    Location
    California
    Posts
    1,928
    +1
    181
    Quote Originally Posted by toxicgun View Post
    part 664130 or even a 664133, I have the emulator so I can take that out or leave it in. N/A 155 GTX 2002.
    bump

  3. #3

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    990
    +1
    57
    Wow....so you do have the dess amplifier....hmmmmm


  4. #4

    Join Date
    May 2012
    Location
    California
    Posts
    1,928
    +1
    181
    Quote Originally Posted by Turboted View Post
    Wow....so you do have the dess amplifier....hmmmmm
    I have the emulator, the amplifier is a different part. Emulator runs on the 664130 computer, Dess amplifier runs on the 664131 computer that you sent me. You sent me the wrong computer and now you are acting like I am a liar?? I asked for a 664130 OR 664133, you sent a 664131 without confirming it would work. GET IT THROUGH YOUR HEAD, they are different and will not interchange without the secondary parts. I have been very civil with you in PM and very clearly explained that I dont have the amplifier, I even sent you the link so you could see what it looks like. If you only knew how wrong you were, you would not be happy about your comment. Hopefully others will chime in here as well to let you know that a 664131 computer will not work on a 664130 ski without the AMPLIFIER that you did not include.

  5. #5

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    990
    +1
    57
    I guess you lear something new every day...well at least I do...have good one....

  6. #6

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    990
    +1
    57
    Ok your right...sorry ....

  7. #7

    Join Date
    May 2012
    Location
    California
    Posts
    1,928
    +1
    181
    Quote Originally Posted by Turboted View Post
    O yea... I guess you still want the head studs...that you never responded too that you said you wanted...lol buddy...
    head studs? What does this have to do with you sending me a completely different ecu then what I requested and you said you sold me? Does that make any sense to you? I was very specific in what I requested, you sent something different that needed another part to work. That is not how this works, you should have confirmed before you sent it out that it was a different part number. Why is this so difficult for you to understand? I requested to purchase a 664130 or 664133, you said you had it, I paid, you sent me a 664131. That is not what I requested, you sent a different part. Seeing how you handle your business I am glad now that I have not purchased anything else from you. Why are you having so much trouble understanding that? You sent a different part than what we agreed on.

  8. #8

    Join Date
    May 2012
    Location
    California
    Posts
    1,928
    +1
    181
    Quote Originally Posted by toxicgun View Post
    head studs? What does this have to do with you sending me a completely different ecu then what I requested and you said you sold me? Does that make any sense to you? I was very specific in what I requested, you sent something different that needed another part to work. That is not how this works, you should have confirmed before you sent it out that it was a different part number. Why is this so difficult for you to understand? I requested to purchase a 664130 or 664133, you said you had it, I paid, you sent me a 664131. That is not what I requested, you sent a different part. Seeing how you handle your business I am glad now that I have not purchased anything else from you. Why are you having so much trouble understanding that? You sent a different part than what we agreed on.
    I like you how you changed your comment, too bad my reply still shows it.

  9. #9
    Quote Originally Posted by toxicgun View Post
    I like you how you changed your comment, too bad my reply still shows it.
    Very good info. to know,sorry about what your going through, hate it when the wrong parts show up at my door,hate it even more when I didn't make the mistake.Then you have a joker on the other end to deal with.good luck.

  10. +1 by:


  11. #10

    Join Date
    May 2012
    Location
    California
    Posts
    1,928
    +1
    181
    so after all this BS, the post office lost the package in transit. So I am still needing this ecu. I have the parts to run 664130, 664131, 664132 or 664133 now. Anyone selling one that can ship quickly?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2002 gtx 4tec
    By TacomaGuy24 in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 09-02-2015, 09:47 AM
  2. WTB - Parts 2002 gtx 4tec ECU
    By tweeker in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-16-2014, 03:46 PM
  3. 2002 GTX 4tec stiff steering
    By Alangsam in forum Sea Doo How To & FAQs
    Replies: 1
    Last Post: 09-08-2013, 01:10 PM
  4. 2002 gtx 4tec compression
    By fireboy in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 04-26-2010, 08:43 PM
  5. 2002 GTX LTD 4Tec
    By Ninja4Hire in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 09-24-2009, 10:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •