Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    mark2m's Avatar
    Join Date
    Mar 2008
    Location
    Greenwood Lake, NY
    Posts
    83
    +1
    3

    Question 2019 RXT-X 300 Fault Codes

    Guys,
    I just picked up a used 19 Rxtx 300 with 17hrs on it and have about 20hrs now. My last couple rides out I enter the settings sub menu and had codes B2A20 B2A21 B2A30 B231. I tried to read the ECM with my Candoo but it couldn't recognize the system. Google search hasn't turned up anything. Any ideas what these codes mean. It seems to run smooth and strong.

    Thanks


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,989
    +1
    2,186
    what those mean?

    we've been trying to get in touch with you about your ford truck warranty

    just give the dealer a call, it's a current year model ski, they will have an answer.

  3. #3
    mark2m's Avatar
    Join Date
    Mar 2008
    Location
    Greenwood Lake, NY
    Posts
    83
    +1
    3
    Thanks I called the dealer and spoke with them. Unfortunately even for them there wasn't much information about what the codes meant. It sounds like Sea doo wants to have the ski go back to the dealer for any service. He thinks it might be related to some body module but the info wasn't clear. So who knows. Only good news is the codes went away over the weekend. It would have been nice to be able to read the ecm with Candoo though.

  4. #4

    Join Date
    Dec 2019
    Location
    Tampa Bay Area, Florida
    Posts
    6
    Any update to this? I have the same issue - codes B2A20 B2A21 B2A30 B231 on a 2019 GTX155 w/ 65 hours. Called service dept at dealer and they were not able to identify the issue / don't know these codes - said to bring it in so they can hook it up. Anyone see these? How did you fix?

  5. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,989
    +1
    2,186
    you want to bring it in. with some luck a firmware update on your ecu will resolve it.

    you haven't sunk that ski have you?

  6. #6

    Join Date
    Dec 2019
    Location
    Tampa Bay Area, Florida
    Posts
    6
    Thanks, will arrange to bring it in. No, have not sunk the ski. Has worked fine, never had any issues.

  7. #7
    mark2m's Avatar
    Join Date
    Mar 2008
    Location
    Greenwood Lake, NY
    Posts
    83
    +1
    3
    Quote Originally Posted by griller View Post
    Any update to this? I have the same issue - codes B2A20 B2A21 B2A30 B231 on a 2019 GTX155 w/ 65 hours. Called service dept at dealer and they were not able to identify the issue / don't know these codes - said to bring it in so they can hook it up. Anyone see these? How did you fix?

    Sorry I haven’t gotten anywhere with the codes. The codes seem to come and go and hasn’t affected performance at all. At least from what I can tell. Report back if the dealer comes up with anything.

  8. #8

    Join Date
    Dec 2019
    Location
    Tampa Bay Area, Florida
    Posts
    6
    I contacted BRP and got a response last night... they said "...those codes are all related to the cluster and wiring harness, not getting voltage and signals."

    So time to take it in for warranty service before I get stuck on the water w/ a dead ski.

  9. #9

    Join Date
    Dec 2019
    Location
    Tampa Bay Area, Florida
    Posts
    6
    Got ski back yesterday after 3 weeks at dealer. They said issue came from the quick-connect battery tender leads. The leads were installed between the battery cable and the battery post and they found this can reduce voltage flow and throw codes. (fyi Leads were originally installed by the dealer at time of purchase).
    They switched the stacking and put the battery tender leads on top and tightened with a ratchet (said this gives better torque the a screwdriver).
    Make sense?

    I rode for a few hours yesterday and no codes.

  10. #10
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,989
    +1
    2,186
    never use a screwdriver to attach a battery. always use the correct size wrench

    in this case it makes absolute sense. The IBR is more sensitive to voltage fluctuations and throws a fit faster then when your wife finds a thong hanging from your trucks radio antenna in the morning

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pull codes from an RXT-X 300?running to
    By Prime Target in forum 4-Tec Performance
    Replies: 5
    Last Post: 02-26-2020, 06:25 PM
  2. color codes from the new SEADOO RXT 300 RS 2019 (black red and gold)
    By SEITAN1111 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-08-2019, 08:39 AM
  3. Engine Fault Codes...fixing on own and clearing codes??
    By rvrkids in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-01-2013, 04:17 PM
  4. 2005 rxt fault codes
    By hognut2000 in forum 4-Tec Performance
    Replies: 21
    Last Post: 04-19-2012, 05:31 PM
  5. 2 hrs on '10 RXT-X, multiple fault codes
    By Romulus in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 03-18-2012, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •