Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 53
  1. #31
    Interesting to follow this
    I also have a 2008 RXP-X with similar mods:
    137+4
    4" home made intake
    Catch can
    Supertech valves and springs
    #28 cam
    55lb injectors
    8800 rpm
    Walbro fuel pump
    FPR
    R&D grate
    83mm nozzle (RXP 2006)
    OEM new RXP 300 intercooler
    Riva thru hull exhaust
    Flame arrestor removed
    SS wear ring
    I had a 15/20 but I hit the rev limiter at like 75% throttle (75 mph)
    So I just installed a new 15/21 instead, will try it on the water in a few days
    I don't have a wedge and haven't filled the ride plate holes yet, don't have any pressure reliefs either 🙈

  2. #32
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    252
    +1
    7
    Was out today for about 30 min just to make sure no leaks. I checked oil when I got back in and I felt it was a tad high. Pulled a little out and it was pretty dark after only 30 min. It is rotella t6. Is this normal. On the stick it still looks new but in the jug it was like charcoal colored. Engine ran great 8640 rpm no speed confirmation yet still tuning fuel

  3. #33
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    9,333
    +1
    1,628
    Quote Originally Posted by Jhubbs255 View Post
    Was out today for about 30 min just to make sure no leaks. I checked oil when I got back in and I felt it was a tad high. Pulled a little out and it was pretty dark after only 30 min. It is rotella t6. Is this normal. On the stick it still looks new but in the jug it was like charcoal colored. Engine ran great 8640 rpm no speed confirmation yet still tuning fuel
    You will want to add some pitch to the prop. You do not want to run that close to the rev limiter or else you will blow the head gasket. Try and dial in the rpms to around 8400-8450 max

  4. #34
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    252
    +1
    7
    Ok will do and thoughts on oil color? Or does it go dark pretty quick. Just don't want water getting in without me knowing. Didn't look brown or white but not pitch black. Maybe a very very dark grey?

  5. #35
    !!!! wave jumper !!!! 05_RXP's Avatar
    Join Date
    Jul 2011
    Location
    Hamilton, Ontario
    Posts
    686
    +1
    41
    Quote Originally Posted by Jhubbs255 View Post
    Ok will do and thoughts on oil color? Or does it go dark pretty quick. Just don't want water getting in without me knowing. Didn't look brown or white but not pitch black. Maybe a very very dark grey?
    I would not be to concerned with the colour of you oil unless it is milky or smells like pure gas. If you do not get the system 100% clean you will end up with tinted oil quickly.


  6. #36
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    252
    +1
    7
    Thank you for the reply. I did this build myself.. 1st time removing the head off a pwc. I replace the oil seal in the water pump took a cple times but initially when I started 1st time on the hose a tiny drip from the water pump occurred. I didn't replace the rubber seal it LOOKED good. I did replace it with a tiny bit of gasket maker and it stopped.

  7. #37
    If you have had the engine apart I would check the oil filter after the first run just to be sure everything is ok

  8. #38
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    252
    +1
    7
    Good idea, what pit h would you recommend currently have a 15/20

  9. #39
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    9,333
    +1
    1,628
    Generally for every degree you add/subtract you will loose or gain 100 rpm. So I would pitch it to a 15/21.


  10. #40
    Jhubbs255's Avatar
    Join Date
    Jul 2018
    Location
    Vandalia Ohio
    Posts
    252
    +1
    7
    Ok. I noticed something odd after the ride. The middle tunnel on the intake manifold did not seam seated completely against the head?? I could barley see the orange from the rubber gasket and could easily fit a razor blade in between the surfaces. I removed added some gasket seal and re installed it fit a little better. I didn't get any performance loss I don't think, but seemed wrong. What could cause this I'm not sure if it was that way before the test ride or not I barley noticed and think the orange rubber was making the seal but anyway what gives? Front and back seem to meet up fine. I'm sure this would cause a boost leak.

Page 4 of 6 FirstFirst ... 23456 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 08 rxpx 255
    By JDELFINO in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-26-2015, 09:28 PM
  2. First pwc rxpx 255
    By Catalac in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-21-2014, 08:01 PM
  3. FS Seadoo rxpx 255 and three seater 255 for sale
    By Cheek in forum Sea Doo 4Tec Skis
    Replies: 6
    Last Post: 05-05-2014, 09:04 PM
  4. 2011 rxpx 255
    By 0rdcbra1 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-15-2012, 08:47 PM
  5. FS Rxpx 255 2008
    By lummy-x in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 11-29-2011, 02:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •