Results 1 to 6 of 6
  1. #1
    IDoSeaDoo's Avatar
    Join Date
    May 2012
    Location
    Davie, FL
    Posts
    314
    +1
    16

    SBT, OEM or WSM for driveshaft?

    Hey guys, I think my driveshaft is bent on my 09 FX HO. I get this ugly vibration at low RPM. I haven't tested it, but I'm suspecting driveshaft rather than prop. Anyone use WSM shafts? They're pretty inexpensive compared to OE or SBT. I hear good things about SBT shafts, but never tried one. I know OE bends (as mine seems to have been bent for the past few years or so). I'm second owner and got it like this. Prop wasn't very damaged when I inspected it. I just cleaned up the edges, but it was in decent shape. No signs of severe damage.

  2. #2

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,949
    +1
    565
    I suppect your shaft is Not the Problem. If your shaft is I would only use OEM parts. More than likely you prop is the problem


  3. #3
    Other than vibration what would make you think your shaft is bent? In my experience a bent shaft is usually the result of sucking up a tow rope and it getting wrapped around the shaft. Take the shaft out and roll it across a hard flat surface it's easy to see any deflection or slight bends.

  4. #4
    IDoSeaDoo's Avatar
    Join Date
    May 2012
    Location
    Davie, FL
    Posts
    314
    +1
    16
    Well, I've had bent shafts in the past on my old seadoos, and that's kind of what it feels like. I can't imagine the prop would be unbalanced enough to cause such a vibration. Could it be something else, like bearings going bad? When I had the pump out, it felt like it turned smoothly and was pretty solid. Very little fwd/back play. What's the typical cause of low end vibration?

  5. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,527
    +1
    2,012
    given the labor involved, OEM

  6. #6
    IDoSeaDoo's Avatar
    Join Date
    May 2012
    Location
    Davie, FL
    Posts
    314
    +1
    16
    Can I run this engine with the driveshaft out? Would like to make sure that vibration goes away with the pump removed. I found some threads suggesting it's the motor. It def. feels more like driveline to me, but it's always good to check.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WSM and SBT Pump driveshafts and bearing kits
    By mdavidthomas in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 05-15-2014, 11:45 PM
  2. Top end rebuild ?'s .... WSM or SBT ?
    By Tturbonegro in forum 2-Stroke Performance
    Replies: 25
    Last Post: 09-24-2011, 11:47 PM
  3. Pro X vs wiseco and sbt vs wsm pistons
    By nikko mercado in forum 2-Stroke Performance
    Replies: 15
    Last Post: 08-01-2011, 09:42 PM
  4. WSM wrist bearings or SBT
    By FLjoyrider in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-13-2007, 07:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •