Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    hassouneh82's Avatar
    Join Date
    Jul 2017
    Location
    Portland Oregon USA
    Posts
    45

    2015 310x wont go over 52mph 6k rpm only 5lbs boost on gauge stalls at full throttle

    Checked fuel pump screen put new plugs in and checked hoses and plug wires. Help pls

  2. #2
    hassouneh82's Avatar
    Join Date
    Jul 2017
    Location
    Portland Oregon USA
    Posts
    45
    Also forgot to mention it misfires and surges. Checked cleaned intercooler

  3. #3

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    1,015
    +1
    163
    Check your exhaust filter then check your belt.. While you are there remove the tensioner then take apart the pivot point, clean and grease..


  4. #4
    hassouneh82's Avatar
    Join Date
    Jul 2017
    Location
    Portland Oregon USA
    Posts
    45
    Ok I'll check it tommorow

  5. #5
    DH300's Avatar
    Join Date
    May 2013
    Location
    Alabama
    Posts
    1,208
    +1
    222
    If it’s surging likely belt slipping. Make sure no water is in the hull next time out.

  6. #6
    hassouneh82's Avatar
    Join Date
    Jul 2017
    Location
    Portland Oregon USA
    Posts
    45
    When I start it out of the water it idles really high and misfires.

  7. #7
    hassouneh82's Avatar
    Join Date
    Jul 2017
    Location
    Portland Oregon USA
    Posts
    45
    At first it had low power but ran ok except under hard acceleration it would just bog down hard as if it was starving for fuel

  8. #8
    hassouneh82's Avatar
    Join Date
    Jul 2017
    Location
    Portland Oregon USA
    Posts
    45
    Now it those things and misfires also hard to go over 10 mph

  9. #9
    hassouneh82's Avatar
    Join Date
    Jul 2017
    Location
    Portland Oregon USA
    Posts
    45
    No water in hull only 40hrs on ski

  10. #10
    hassouneh82's Avatar
    Join Date
    Jul 2017
    Location
    Portland Oregon USA
    Posts
    45
    Click image for larger version. 

Name:	1563146903589.jpeg 
Views:	24 
Size:	112.4 KB 
ID:	450891Click image for larger version. 

Name:	1563146934284.jpeg 
Views:	24 
Size:	94.6 KB 
ID:	450892Click image for larger version. 

Name:	1563146955301.jpeg 
Views:	24 
Size:	140.4 KB 
ID:	450893

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2015 310X SE - Low Boost, RPM, & Speed (1st post updated)
    By UnleashedBeast in forum Kawasaki How To & FAQs
    Replies: 372
    Last Post: 08-14-2016, 10:39 PM
  2. Replies: 34
    Last Post: 05-13-2016, 06:43 AM
  3. Engine stalls on full throttle
    By Todd3682 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 08-07-2015, 08:56 PM
  4. 2007 STX 12F stalls and wont go past 5k RPM in water, idles and hits 7k RPM on land
    By vwmikey99 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 17
    Last Post: 07-20-2013, 08:35 AM
  5. 2001 Virage stalls at full throttle
    By tcar321 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 04-17-2011, 10:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •