Results 1 to 9 of 9
  1. #1
    woodsrider40's Avatar
    Join Date
    Jul 2012
    Location
    Clinton TN
    Posts
    241
    +1
    8

    2004 Seadoo GTI le RFI not right

    Hello all, I am dealing with a GTI le RFI at frist the MPEM and ECU was bad replaced with a good used one and replaced the stator new. It runs good straight till I turn it struggles to get the RPM's up and also does it when let up throttle then back on once it gets going which doesn't take but a split second it's runs good. I did reset the TPS to see if that's could be the problem still the same old thing. Checked fuel pressure which is at 60 psi and check pressure while riding never changed stays at 60. I'm lost at this point. I was thinking it could be the fuel filter in the pump but wanted to check to see any of you had this problem and what you did to fix it.


  2. #2
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,413
    +1
    137
    Can you explain your issue a little clearer.....is it starving for fuel ??? What is the history of the machine ?? When was the last time it ran right ??

  3. #3
    woodsrider40's Avatar
    Join Date
    Jul 2012
    Location
    Clinton TN
    Posts
    241
    +1
    8
    He bought the ski with a bad motor so he went with an SBT remain it ran good for a year and a half then the stator had a heat soak replaced that it did run better but shuts down so got an good low hour MPEM runs good straight until I let up on the throttle in turns then back on it either starving or flooding the reason I say flooding when the ski is shut off for a few minutes sometimes it's hard to start until I give a little throttle and sometimes running rough then found the rear plug more wetter then the front so replace the plugs all good again (not all the time maybe I changed the plugs 3 time.). When you let off the throttle completely till idle down then back on it also struggles till on plane but it doesn't take long to clean out it runs good and if keep the sped it's ok. It only struggles when letting off the gas. Like I said the fuel pressure is at 60 psi even when riding it. I hope this helps a little better. I did check compression which was 150 psi in both holes.

  4. #4
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,413
    +1
    137
    Was the stator replaced with a OEM or aftermarket ??

  5. #5
    woodsrider40's Avatar
    Join Date
    Jul 2012
    Location
    Clinton TN
    Posts
    241
    +1
    8
    He bought the aftermarket I believe was a Rick stator if I remember correctly. You think it might be the stator ?

  6. #6
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,413
    +1
    137
    IMO most aftermarket is junk.

    I have a oem stator if you wanna try one. $75 shipped.

    Seems like most problems started after the AM one was installed.

  7. #7
    woodsrider40's Avatar
    Join Date
    Jul 2012
    Location
    Clinton TN
    Posts
    241
    +1
    8
    It doesn't hurt to try, I'll take it if it good I will leave it in. PM me your PayPal. Thank you.

  8. #8
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,413
    +1
    137
    Before you do anything else I would check the jet pump oil...

  9. #9
    woodsrider40's Avatar
    Join Date
    Jul 2012
    Location
    Clinton TN
    Posts
    241
    +1
    8
    The oil is new so replace it when I checked the pump. It doesn't hurt to check it again to be sure no binding, anything could happen from then till now. Money sent.
    Thank you

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 Seadoo Gti Rfi Le
    By Reloaded28 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-24-2015, 04:31 PM
  2. 2004 Seadoo GTI LE RFI WONT START LOOSE CONNECTION?
    By JohnMone in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-08-2014, 10:42 AM
  3. seadoo gti le rfi 2004 shaft
    By seadoo gti le rfi110hp in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-23-2013, 06:22 PM
  4. WTB Looking for Seadoo hood for a 2004 GTI RFI with mirrors
    By Snipescastle2 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-12-2011, 11:13 AM
  5. Replies: 0
    Last Post: 07-10-2008, 06:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •