Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27
  1. #11

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    997
    +1
    59
    Check opas...make sure its working..

  2. #12

    Join Date
    Aug 2014
    Location
    Harwood, MD
    Posts
    86
    Quote Originally Posted by toxicgun View Post
    110 compression is also low, very low. Good numbers for a 2 stroke but not 4 stroke.
    That is with the super charger hose off. Would that matter?

  3. #13

    Join Date
    Aug 2014
    Location
    Harwood, MD
    Posts
    86
    Quote Originally Posted by Turboted View Post
    Check opas...make sure its working..
    Is the opas the solenoid were you add the oil to the engine? If so I hear it clicking and pulling in.


  4. #14
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Grande Prairie, AB, CA
    Posts
    2,041
    +1
    80
    Good 135-145
    OK 115-135
    Bad less than 115

    Did you check it warm or cold

  5. #15

    Join Date
    Aug 2014
    Location
    Harwood, MD
    Posts
    86
    Checked it cold with the supercharger hose on this time. Getting 119-120 on the three cylinders. Rebuilt the supercharger and no difference. Pulled the fuel injectors out and all three are spraying equally the same. What would be a normal fuel pressure? I have not checked that yet.

  6. #16
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Grande Prairie, AB, CA
    Posts
    2,041
    +1
    80

    Stock 2004 185 HP not going over 50 MPH

    You’ve checked the impeller and wear ring right? That can play a huge difference in performance

    Edit: NVM saw you checked it already. Have you checked for a possible boost leak?

  7. #17
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,077
    +1
    784
    Quote Originally Posted by Racerx886 View Post
    Checked it cold with the supercharger hose on this time. Getting 119-120 on the three cylinders. Rebuilt the supercharger and no difference. Pulled the fuel injectors out and all three are spraying equally the same. What would be a normal fuel pressure? I have not checked that yet.
    Normal fuel pressure is around 58 psi.

    Have you checked the obvious, impeller has no damage, nose cone securely attached or removed?

    OPAS is Off Powered Assist System, only helps turn the ski at slow speeds, they are out of the water when on plane.

    Throttle body cable should have just a little slack in it. Boost leaks could cause low rpm also, check the SC to TB hose and clamps, then check the intake manifold for a split in the seams.

    Good luck.

  8. #18

    Join Date
    Aug 2014
    Location
    Harwood, MD
    Posts
    86
    Thanks for all the help, I will do some more checking. One ting I should correct is that the ski will hit 57 MPH but it has hit 63 MPH just a few weeks ago. Really only looking for 5 MPH that I have lost. The ski a few weeks ago would hit the rev limiter from a dead stop coming out of the water. It will not do that now. I haven't given up but I thought I would have found the issue by now.

  9. #19
    Quote Originally Posted by jpt7779 View Post

    OPAS is Off Powered Assist System, only helps turn the ski at slow speeds, they are out of the water when on plane.
    How do you check the OPAS? Seems like it would be hard to see while driving but you really need to see that it moves while driving.

  10. #20

    Join Date
    Aug 2014
    Location
    Harwood, MD
    Posts
    86
    Trying to find a way to check the fuel pressure. Went to the auto parts store but they do not have the correct fitting to connect to the fuel line schrader fitting. Anyone know what the correct fitting size is?

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with Modding a 2004 185
    By 4skis in forum 4-Tec Performance
    Replies: 13
    Last Post: 03-15-2014, 02:35 PM
  2. Supercharger slipping? Gtx 185 wont go over 48 mph help!!
    By crzyjetskr in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-25-2011, 09:34 PM
  3. 2004 Gtx Sc 185 Hp
    By Gunguy in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-09-2008, 09:14 PM
  4. 2004 Gtx Sc 185 Hp
    By Gunguy in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-26-2008, 09:33 PM
  5. 2004 rxp stock only 7600 rpms,63 mph
    By joe563 in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-01-2007, 12:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •