Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35
  1. #21

    Join Date
    Nov 2018
    Location
    North Carolina on Jordan Lake
    Posts
    133
    +1
    11
    Did this happen after the ECM was reflash? If yes, most likely a corrupt reflash. Have it flashed again. Better yet have Dean or Riva reflash it. My opinion only.
    Last edited by cjk6119; 10-10-2019 at 02:37 PM.

  2. #22

    Join Date
    Jul 2019
    Location
    Australia
    Posts
    18
    reflashed tune then swapped it from worx to riva still no change about to reflash back to stock to see if itís map sensor reader over boost

  3. #23

    Join Date
    Jul 2019
    Location
    Australia
    Posts
    18
    itís definitely not the remote have already done inline fuel gauge itís all good iím up to sensors now itís like itís pulling timing once it hits 8350rpm and drops back to 5500rpm

    HI Guys,
    I have a 2017 FXSVHO 68hours and its been really reliable but soon after finishing my Mods (Worx Cooling upgrade, Worx hi flow strainer, Worx Airfilter kit, Worx intake grate, worx ecu reflash, swapped to solas impeller to correct pitch as per Worx recommendation , Worx Trim extender, Worx billet throttle body damper. Worx ribbon delete, Worx pump seal kit.)

    From CJ
    I would think his remote that might be in a compartment is being accidently pressed and going into a lower performance mode or a bad knock sensor retarding the timing. I first would install plugs gapped at .31-.35 and take it for a ride with a fuel pressure gauge inline to see if it is a fuel pressure regulator or not.
    Hope this is of help to you.

    Take Care Yamsvho
    C J

    The spec for your ski`s fuel pressure from the RP Manual is 50to 51.5 psi .
    Knock sensor check disconnect the knock sensor and check the resistance should be between 504.0 -616.0 ohms or disconnect the sensor and take it for a ride and see if the problem is resolved. the knock sensor will not always trip a code if they are going bad[/QUOTE]

  4. #24

    Join Date
    Nov 2018
    Location
    North Carolina on Jordan Lake
    Posts
    133
    +1
    11
    Then the lower performance might just be a bad knock sensor retarding the timing. Disconnect the sensor and take it for a ride and see if the problem is resolved.

    If it’s a map sensor reader over boost condition ,I would think it would set a code. Is the tune requiring a 2 or 3 bar map sensor?


    Another thing is there maybe too much timing in the tune and the knock sensor is just doing it`s job protecting the engine so be careful if you do disconnect the sensor and listen for any pinging and don't hold the throttle open too long just enough for testing. I think you are on the right track. Hope you get it solved.

    CJ
    Last edited by cjk6119; 10-11-2019 at 09:38 AM.

  5. #25

    Join Date
    Jul 2019
    Location
    Australia
    Posts
    18
    thanks hanks man i think i will replace the knock sensor first see how it goes, tune shouldnít need the upgraded map sensor but may look at that next




    Quote Originally Posted by cjk6119 View Post
    Then the lower performance might just be a bad knock sensor retarding the timing. Disconnect the sensor and take it for a ride and see if the problem is resolved.

    If itís a map sensor reader over boost condition ,I would think it would set a code. Is the tune requiring a 2 or 3 bar map sensor?


    Another thing is there maybe too much timing in the tune and the knock sensor is just doing it`s job protecting the engine so be careful if you do disconnect the sensor and listen for any pinging and don't hold the throttle open too long just enough for testing. I think you are on the right track. Hope you get it solved.

    CJ

  6. #26

    Join Date
    Nov 2018
    Location
    North Carolina on Jordan Lake
    Posts
    133
    +1
    11
    To Yamsvho
    I was thinking last night about your problem and It could be anything that is loose on the engine creating a rattle or vibration ( like a loose intake manifold brackets under the intake ). These vibrations are known to be picked up by the knock sensors retarding the timing.


    Take Care

    C J

  7. #27

    Join Date
    Jul 2019
    Location
    Australia
    Posts
    18
    thanks mate, i will pull it all out and reinstall it just to make sure, iíve done it that many times iím a pro at it now 😂😂

    Quote Originally Posted by cjk6119 View Post
    To Yamsvho
    I was thinking last night about your problem and It could be anything that is loose on the engine creating a rattle or vibration ( like a loose intake manifold brackets under the intake ). These vibrations are known to be picked up by the knock sensors retarding the timing.


    Take Care

    C J

  8. #28
    BLASTER 1's Avatar
    Join Date
    Jul 2015
    Location
    GRIDLEY, CA
    Posts
    652
    +1
    131
    Still sounds like it’s your clutch, like others have stated. Even if you can only spin the charger wheel one way doesn’t mean it’s good. If it has any movement or just slightly mushy it’s going out

  9. +1 by:


  10. #29

    Join Date
    Jul 2019
    Location
    Australia
    Posts
    18
    We replaced the clutch no change 😔

    Quote Originally Posted by BLASTER 1 View Post
    Still sounds like itís your clutch, like others have stated. Even if you can only spin the charger wheel one way doesnít mean itís good. If it has any movement or just slightly mushy itís going out


  11. #30
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,544
    +1
    211
    Did you find the problem
    I was thinking it could also be getting hot and going into limp mode

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2018 FXSVHO Versus 2015 FXSVHO
    By philsgp in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 12-23-2017, 06:36 PM
  2. 2014 fxsvho vs 2015 fxsvho. Any difference?
    By jeel in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 02-07-2016, 08:42 AM
  3. 2014 fxsvho vs 2015 fxsvho ...any difference
    By jeel in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 02-04-2016, 07:55 PM
  4. Intermittent Loss of Power above 6000 RPM. Power Valves? - GP800R
    By mfabel in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-29-2015, 05:34 PM
  5. 2007 RXP oil loss/power loss
    By Mcr1994 in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-30-2013, 10:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •