Results 1 to 5 of 5
  1. #1
    Tbeercheck's Avatar
    Join Date
    Sep 2016
    Location
    Marblehead /Westlake Ohio
    Posts
    37

    Heavy vibration full throttle

    Hi my brother in-law haze a 2012 VX Cruiser that is vibrating under full throttle. I was thinking it could be the impeller ? The RPMS are 8000 with low power . He isn’t one to install fresh plugs at the beginning of the year . Just spit balling. Any help would be appreciated thank you

  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,579
    +1
    1,905
    Quote Originally Posted by Tbeercheck View Post
    Hi my brother in-law haze a 2012 VX Cruiser that is vibrating under full throttle. I was thinking it could be the impeller ? The RPMS are 8000 with low power . He isn’t one to install fresh plugs at the beginning of the year . Just spit balling. Any help would be appreciated thank you
    What do you mean by ‘low power’?

    Is the engine revving high but there is weak thrust from the jet pump? If yes, inspect the impeller in the jet pump for debris.

  3. #3
    Flash's Avatar
    Join Date
    Feb 2008
    Location
    Phoenix Az
    Posts
    552
    +1
    23
    Quote Originally Posted by Tbeercheck View Post
    Hi my brother in-law haze a 2012 VX Cruiser that is vibrating under full throttle. I was thinking it could be the impeller ? The RPMS are 8000 with low power . He isn’t one to install fresh plugs at the beginning of the year . Just spit balling. Any help would be appreciated thank you
    Sounds like possible debris inside the intake or prop.

  4. #4
    Erierunner's Avatar
    Join Date
    Aug 2014
    Location
    Erie, PA
    Posts
    659
    +1
    88
    8,000rpms at wide open is where that MR-1 should be. If vibration and low power, I would suspect the impeller or debris with low power.

  5. #5

    Join Date
    Feb 2016
    Location
    Georgia
    Posts
    402
    +1
    67
    if you have even a small chunk of debris like a piece of wood, some plastic, a piece rope, fishing line, anything at all in the blades, you will get vibration. Also, see if any of the blades are chipped, cracked dinged or bent. You can just shine a flashlight up through the intake grate to do an inspection. There are other potential causes but those are the typical ones.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Random Vibration at full throttle
    By not2fast in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-14-2017, 10:40 AM
  2. Heavy vibration normal with a 650 with high compression?
    By airbats801 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 09-09-2016, 12:16 AM
  3. gpr1200 runs good till 3/4 throttle then loses rpms and speed at full throttle
    By zigp1212 in forum Yamaha PWC Performance (2-stroke)
    Replies: 34
    Last Post: 08-11-2013, 08:35 AM
  4. gp800r 'missing' at full throttle and when applying throttle
    By jim mcgreehan in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-24-2012, 03:54 PM
  5. Loss of power and heavy vibration
    By taxsux in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-23-2011, 07:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •