Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27
  1. #11
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    9,176
    +1
    1,536
    Hey Bob. I have an older one that when I took it apart it looked just like that


  2. #12
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,756
    +1
    910
    I had stainless springs made for that regulator. I can make another run if there's enough interest. $19 per spring


  3. #13
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,059
    +1
    1,890
    Quote Originally Posted by JFizzleJR View Post
    I had stainless springs made for that regulator. I can make another run if there's enough interest. $19 per spring
    I'm interested. Post it here or pm me when you make a few more. I WILL buy 2.

  4. #14
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    649
    +1
    59
    Where you found a new brass fitting?

    I found the threaded piece back in the hull, came out due vibration I guess...

    Attachment 450470

  5. #15
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,059
    +1
    1,890
    Quote Originally Posted by EVN81 View Post
    Where you found a new brass fitting?

    I found the threaded piece back in the hull, came out due vibration I guess...

    Attachment 450470



    I found a replacement fitting at the local Ace Hardware store.

  6. #16
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,085
    +1
    793
    Quote Originally Posted by 1tommygunner1927 View Post
    Gents, I didn't post this to bash Riva. This rrfpr was purchased new 2010, used on my 2008 TX and now on my 2013 TX. It has work flawlessly for 9 years. I am simply suggesting the spring needs to be updated for marine use.
    Ok Bob, I’ll come clean........I’ve been peeing in your gas so that you stay slower than me!

  7. +1 by:


  8. #17
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,059
    +1
    1,890
    LOL I was going to buy 2.............

  9. #18
    Hursty7's Avatar
    Join Date
    Sep 2017
    Location
    Sarnia, Ontario, Canada
    Posts
    103
    +1
    10
    Quote Originally Posted by JFizzleJR View Post
    I had stainless springs made for that regulator. I can make another run if there's enough interest. $19 per spring
    I would take one mine is only a year old. I like shiny parts tho.


    And what about intercooler condensation... because this is KILLLING me at WOT.. I'm thinking a inlet hose clamp and throttle the water going to my IC, these things are beats at condensing the humid air with our water temp right now...

    anything above 10PSI boost I can feel the condensation getting blown by (pressure tested I/C end of last season- no issues)
    Last edited by Hursty7; 07-07-2019 at 01:41 PM.

  10. #19
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,059
    +1
    1,890
    Well....you need more boost! I'm pushing 20 psi. All I get is hold the hell on!

  11. #20
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,756
    +1
    352
    Quote Originally Posted by Hursty7 View Post
    Sold, mine is only a year old. I like shiny parts tho.


    And what about intercooler condensation... because this is KILLLING me at WOT.. I'm thinking a inlet hose clamp and throttle the water going to my IC, these things are beats at condensing the humid air with our water temp right now...

    anything above 10PSI boost I can feel the condensation getting blown by (pressure tested I/C end of last season- no issues)
    You shouldnt have condensation issues above 7000rpm, you have the 135 wheel? Something else is going on, our lake and air temps are very similar. With my 142 setup, it runs alot hotter and only condensation I have with my fizzle aside from on the outside is if I'm idling thru a no wake zone.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fizzle condensation?
    By Chrisf in forum 4-Tec Performance
    Replies: 18
    Last Post: 04-18-2016, 08:45 AM
  2. What's this? Condensation?
    By samy-gti in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 03-13-2016, 11:24 PM
  3. Condensation on gauges
    By massguy in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 03-18-2012, 08:45 AM
  4. IC Condensation
    By jmatak9 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 18
    Last Post: 11-18-2009, 03:55 PM
  5. Condensation
    By Gregg in forum 4-Tec Performance
    Replies: 11
    Last Post: 11-08-2007, 07:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •